Plone 5.0.8 ==> 5.1 Migration-Error

I have a website that was created on Plone 5.0.8, I had tried 5.1rc1 at the time but was receiving a strange database error, therefore I decided to stick with an older version. Now I want to migrate to Plone 5.1 but I'm facing a strange issue which I cannot figure out.

Running my buildout with P5.1 runs smoothly, there's no errors - however when accessing the Zope interface and then trying to proceed with the migration just shows me an empty page, the same result is shown when trying to migrate through the Plone site itself.

Here's a quick demonstration...

As you can see, nothing is shown? Can I force the migration through some fallback view or by some other means, I'm not sure why this is happening.


zc.buildout == 2.9.5
setuptools == 37.0.0


some.webapp =

setuptools = 37.0.0
zc.buildout = 2.9.5
PyYAML = 3.12
argh = 0.26.2
args = 0.1.0
check-manifest = 0.35
clint = 0.5.1
colorama = 0.3.7
configparser = 3.5.0
coverage = 3.7.1
createcoverage = 1.5
enum34 = 1.1.6
flake8 = 3.3.0
flake8-blind-except = 0.1.1
flake8-coding = 1.3.0
flake8-debugger = 1.4.0
flake8-deprecated = 1.1
flake8-isort = 2.1.3
flake8-pep3101 = 1.0
flake8-plone-api = 1.2
flake8-plone-hasattr = 0.1
flake8-polyfill = 1.0.1
flake8-print = 2.0.2
flake8-quotes = 0.9.0
flake8-string-format = 0.2.3
flake8-todo = 0.7
isort = 4.2.5
mccabe = 0.6.1
pathtools = 0.1.2
pkginfo = 1.4.1
plone.recipe.codeanalysis = 2.2
plone.testing = 5.0.0
pycodestyle = 2.3.1
pyflakes = 1.5.0
requests-toolbelt = 0.7.1
testfixtures = 4.13.4
twine = 1.8.1
watchdog = 0.8.3
z3c.jbot = 0.7.2
zest.releaser = 6.9

i18ndude = 4.3

# Works with Firefox 55 & Firefox 52
robotframework = 3.0.2
robotframework-debuglibrary = 1.0.1 = 1.1.1
robotframework-selenium2library = 1.8.0
robotframework-selenium2screenshots = 0.7.2
robotsuite = 2.0.0
selenium = 3.5.0
prompt-toolkit = 1.0.15
wcwidth = 0.1.7

I have very recently seen a similar problem report in this forum. When I remember right, the issue could be resolved. Search for the corresponding discussion.

Been searching through the forum but I'll be honest, I haven't yet found something similar...
Any ideas, do you have a link to the post..?
I tried searching for...

"portal_migration view empty / blank / error"
"plone 5.1 migration error / empty"

To be honest not sure what to search for...

I am following this forum since less than 4 months but when dealing with migrations to 5.1 it should be enough and I don't remember it either. What has been posted is this post about adding content after migration but it seems a different issue.

Probably, I have been wrong: the discussion I had in mind likely had to do with blank pages related to "varnish" and not related to a migration.

@gp54321 that looks like the issue, seems to be a known issue, though it's resolved in a later release... Interesting...

from what I remember the problem with this first problem was adding content after a seemingly successful migration, if I understand correctly your post the migration don't even start.

@gp54321 Yup I'm post migration, but that would mean I've hit an edge-case or the issue can be replicated in other scenarios other than after migration.

problems seems related to use of a not-really-supported add-on that I don't see in your buildout

I hope that you solved your problem, if not I have 3 more pieces of advice:

  1. try to start migration in foreground mode (instance fg or something like that) and look at console messages.

  2. if migration crashes in 1), you can try to (dry) run the upgrade in debug mode like this:

>>> plone=app.Plone
>>> from zope.component.hooks import setSite
>>> setSite(plone)
>>> from plone import api
>>> import logging
>>> logger = logging.getLogger('')
>>> logger.setLevel(logging.DEBUG)
>>> pm=plone.portal_migration
>>> report=pm.upgrade(dry_run=True,swallow_errors=False)

if there is a crash while migrating, this should give you a backtrace
If not for x in report.split('\n'): print x should give you the log (but in your case it should not go so far since your migration does not work)

  1. if all else fails you could try to create a new, empty 5.1 site with all your add-ons and test the compatibility of these add-ons on this test site. If you find that an add-on is problematic, remove it from your original site and try again the migration. If your new 5.1 site works with all your add-ons, copy the data directory from the old 5.08 site to the new and start the migration.
1 Like

I'm going to give these all a try, I appreciate your time. Thankyou! I'll post an update back here when I know more...