Plone-4.3.15-UnifiedInstaller: error in building libxml2/libxslt system libraries

Hello, i hope this is the right place to post such an issue.

I am in the process of bringing our two Plone sites from a partially broken upgrade to 4.3.2 (most of the zope security stuff got missing on the objects, so strange errors and only Image and File objects were addable, although the sites were delivering content well), so we decided to set up the latest stable 4.3 version and recreate the content by hand on a fresh install as a new base.

So while after several tests the 4.3.2 Unfiied installer works well, the 4.3.15, which is as today the latest stable from this version branch, gives the following error. I tried to figure out whats going wrong, but have no clue in how buildout, the recipes, involved setuptools and python all work together and maybe depend on each other in specific versions. I can not even find out how it is determined which zc.buildout version is used to buildout the lxml-static buildout.

Anyway here is the invoked command from the Unifed 3.1.15 with error:

./install.sh --target=/usr/local/Plone4.3.15 --static-lxml --build-python zeo

...
Building lxml with static libxml2/libxslt; this requires Internet access,
and takes a while...

lxml build failed.
See log file for details.

and the install.log:

...
Develop: '/usr/local/Plone4.3.15/zeocluster/src/z3c.recipe.staticlxml'
Couldn't find index page for 'zc.recipe.cmmi' (maybe misspelled?)
Getting distribution for 'zc.recipe.cmmi==1.3.6'.
Couldn't find index page for 'zc.recipe.cmmi' (maybe misspelled?)
While:
  Installing.
  Getting section lxml.
  Initializing section lxml.
  Installing recipe z3c.recipe.staticlxml.
  Getting distribution for 'zc.recipe.cmmi==1.3.6'.
Error: Couldn't find a distribution for 'zc.recipe.cmmi==1.3.6'.

Please note that a 4.3.2 with the same command succeeds (in another location)
I tested poth the Plone-4.3.15-UnifiedInstaller and the Plone-4.3.15-UnifiedInstaller-r2 version, both give the same error.

index = https://pypi.python.org/simple

Please add this to your Buildout.

Thank you, that worked out!

The affected buildout in the UnfiiedInstaller is the base_skeleton/lxml_static.cfg, and after the install has run, the buildout.cfg in the zeocluster/zinstance directory is affected, too.

@svx or @smcmahon can you help us here in the 4.3.x branch? To avoid these problems to new users when downloading the UnifiedInstaller?

Plone Foundation Code of Conduct