PAS plugin silently unavailable

We're running Zope 2.10.6

I followed the Zope Dev Guide and the old PAS ReadTheDocs. I've also looked at existing PAS Plugins.

I believe I've properly implemented a custom PAS Plugin.
I added my plugin to buildout.cfg in the develop = attribute.

I ran:

bin/zopectl stop
bin/buildout -Nov
bin/zopectl start

The output from buildout indicates my plugin built. I know it was attempting it because initially I had a couple errors to resolve.

My instance.log does not have any errors for the most recent start.

Yet, in the ZMI, I do not see my plugin as an option within a PAS folder.
Where else can I look to try and resolve this issue?

It sure would help if the old tutorials had not been wiped from the face of the planet. I can't be the only developer having to continue limping along on old Zope?
Is this tutorial available anywhere ??? http://plone.org/documentation/manual/developer-manual/archetypes/appendix-practicals/b-org-creating-content-types-the-plone-2.5-way/writing-a-custom-pas-plug-in

In a modern world, the "add list" is controlled by provided interfaces. Not sure whether Zope 2.10 is modern enough.

Apparently, you have a Products.PluggableAuthService version compatible with your Zope version. It comes with plugins. Look at their code (and especially how they are registered during initialization) to have examples.

3 Likes

There is a copy from 2011 in the wayback machine.

1 Like

Thank you. I've tried wayback machine before for old Zope docs and always come up empty. I guess I tried looking for the old zope.org version of this doc before, and forgot to try again for the plone.org version.

As a follow-up, I did eventually get my plugin to show up in the Add-list.
What's infuriating is that it did not show up in the Add-list when I tried adding it as a develop-egg, it also did not show up in the Add-list when I moved it into the products directory as an old-Zope Product.
It finally showed up in the Add-list when I moved it into the parts/plone/PluggableAuthService product as a built-in plugin within PAS itself.

In all 3 cases, my code did not change (except for the filenames when moved within PAS).

My plugin still is not working, but that is a separate issue for a new thread.

If you're running Plone, it is the common setup. Beware that running buildout will erase the parts folder, because it will be rebuilded.

Plone Foundation Code of Conduct