On Plone 4.3.15, how to install latest Stripe's API

On Plone 4.3.15 (Universal installation), it is not possible to install stripe 2.32.1. See logs :

Getting distribution for 'stripe==2.32.1'.
/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'project_urls'
  warnings.warn(msg)
/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'long_description_content_type'
  warnings.warn(msg)
error: Setup script exited with error in stripe setup command: 'install_requires' must be a string or list of strings containing valid project/version requirement specifiers
An error occurred when trying to install stripe 2.32.1. Look above this message for any errors that were output by easy_install.
While:
  Installing instance.
  Getting distribution for 'stripe==2.32.1'.
Error: Couldn't install: stripe 2.32.1

It seems that easy_install / Setuptools is too old ? Do I need to upgrade Setuptool ? If so, how can it be done ?

Plone Foundation Code of Conduct