No more access to the history views after migrating from 4.3 to 5.1

Hi,

Another woe in my migration attempts, and that one is a real blocker.

Whatever the 5.x version I tried to migrate to from our (add-on free) 4.3.18 instance, installing and migrating to Dexterity or not, after migration I cannot use the "view history" button in the navigation portlet to display the history view of the object displayed in the main page.

Hovering (and clicking) over the button, my browser (tried with Firefox and Chromium) displays the following link :

http://localhost:8080/intranet/some/url/?_authenticator=....

The only way to access the history view is to edit the URL manually, adding the @@historyview thingie.

What went wrong and how can I fix this?

TIA,

phep

This is the challenge I am currently facing. I would like to see [history] button in the menu of the pages and dexterity content types to point to the history view

Using the /@@historyview does show the changes but I don't see any UI elements in Plone 5.x

Please be aware that the history on Archetypes content from Plone 4.3 is not migrated by the included inplace atct_migrator tool to the new Dexterity content type system. Only the current/live version is migrated to dexterity.

Plone Foundation Code of Conduct