No 'instancehome' following online Zope2 install/run documentation

Hello.
I followed zope readthedocs io/en/2.13/INSTALL-virtualenv.html. (BTW, I first tried the buildout directions. These cannot work because the 2.13.30 tarball does not have bootstrap included.)
Everything succeeded.
I used bin/mkzopeinstance -d . to create my Zope instance.
When I went to the next page, zope readthedocs io/en/2.13/operation.html, I cannot get Zope to start.
I tried bin/zopectl start and /vol/plone/Zope2.13/bin/zopectl start and /vol/plone/Zope2.13/bin/zopectl start -c /vol/plone/Zope2.13/etc/zope.conf.
Each time gave the same result: AttributeError: 'NoneType' object has no attribute 'instancehome'
Here is the relevant section of my zope.conf:

$ head etc/zope.conf
%define INSTANCE /vol/plone/Zope2.13
instancehome $INSTANCE
%define CLIENT_HOME $INSTANCE/var
clienthome $CLIENT_HOME

products $INSTANCE/Products
#products $INSTANCE/parts/productdistros
#products $INSTANCE/parts/plone
debug-mode off
security-policy-implementation C

Any suggestions to get this installation up and running will be much appreciated.

Modern zc.buildout versions no longer require a separate bootstrap.

The file names I see in your zope.conf suggests that you are in fact targeting Plone. Then you could try the Plone installer - it would set up Plone and as part of it Zope. Until Plone 5.1, you would get Zope 2.13; from Plone 5.2 on, you get Zope 4.

1 Like

Thank you for your answer.
I am trying to bring myself up to speed regarding Zope/Plone.

Further discussion has revealed that the Plone installer likely was used in the past.

I downloaded the Plone Universal Installer 5.1.6 and ran it.
It failed because it could not download buildout.sanitycheck.
I was able to have the virtualenv's pip install the requisite version of buildout.sanitycheck.
Will running bin/buildout complete what the Universal Installer started? or was the Universal Installer supposed to do more?

Regarding Plone buildout configuration I'd recommend the Starzel buildout here: https://github.com/starzel/buildout ... there you have all versions from 4.3 'till latest ... checkout the README

Plone Foundation Code of Conduct