Mxdev and pip option --install-option="--pre"

with a mx.ini

requirements-in = requirements.txt
requirements-out = requirements-mxdev.txt
contraints-out = constraints-mxdev.txt
version-overrides =

url =
branch = fix-issue-with-plone.restapi

if i run mxdev -c mx.ini mxdev generate a requirements-mxdev.txt with this piece of configuration

-e ./sources/Zope --install-option="--pre"

but this make problems in my ci enviroment.

I notice ''--install-option" is deprecated or removed in pip 23.1. Is there an alterantive? Or should i correct the requirements-mxdev.txt via sed command?

perhaps @jensens has a opnion or solution?

I have a fix already local, but it lacks deeper testing. I'll prepare a PR soon.
Meanwhile you can pin to pip==23.0.1 (constraints.txt) and if you use a Makefile then update the pip install pip ... line to @${PYBIN}pip install -U "pip==23.0.1" wheel setuptools.


I had theI had the exact same issue and the recommendation from @jensens fixed it for me.

Fixed in main Fix usage of "--install-option='pre'" and use "--pre" option in requirements files instead. by thet · Pull Request #30 · mxstack/mxdev · GitHub
Thanks @thet and @fredvd for fixing.

I released mxdev 3.0.0b3 with the fix included.

@rnixx and I are planning a final 3.0.0 release within the next weeks.

1 Like

I have checked the new beta3 version. My CI runs without errors. Thanks @jensens !