Missing fields in Add Page after upgrading to Plone 5.1.0

Something strange has occurred. After upgrading to Plone 5.1.0, I can no longer add new content. I can edit old pages but not add new ones. When I click on Add Page, a blank page with no fields appear. Even on a new Plone site, when I click Add Page, Add File or anything else, the page is blank. Since there are no fields for me to input, I cannot add anything new.

If I install a new Plone 5.1.0 altogether, I have no issues there. It is with the upgrade from 5.0.8 to 5.1.0 that has brought this about. Does anyone know what could be the issues here? Any help would be most appreciated. Thank you.

Do you have Products.CMFDefault installed? or plone.app.ldap, which depends on CMFDefault?

Also see Upgraded site from 5.0.8 to 5.1 and now I can't add content

Thanks so much, Chrissy.

So here is my set up. I have the front end on one server and the Data.fs resides on another server. I started this with Plone 5.0.7:

  1. Plone 5.0.7 on Server1 and Plone 5.0.7 on Server 2 (not running Plone but only using data.fs on Server 2) -- worked perfectly

  2. Upgraded to Plone 5.0.8 on Server1 and did not touch Server2 -- worked perfectly

  3. Upgraded to Plone 5.1.0 on Server1 and did not touch Server2 -- worked perfectly

  4. Upgraded to Plone 5.1.0 on Server1 and upgraded to Plone 5.1.0 (thinking that it would be best to keep things compatible) -- I could no longer add new content (even after adding Products.CMFPlone-meta:meta-bbb.zcml to both Server 1 and 2 buildouts)

  5. When I run Plone on Server2 which connects to the same Data.fs, I could add new content

So my question is, when I only use the Data.fs without running Plone on server2, should I have just have left it alone? What could be happening here? Thanks so much.

So here's the deal. I decided to change the Plone ports on Server1 and Plone database port on Server2 and lo and behold, everything is working now. I changed it back to its original ports and it is working as it should now. My forms now have fields. I don't even know why changing to new ports and changing it back to its old ports would make it work. But it does now! Thanks!