Matplotlib integration

Guys ,
I was trying to implement matplotlib in plone using my own addon. I added it to the install_requires in the file. But it is showing error. I not only want matplot lib but any python library for the data analysis purpose. Kindly help me with the query. I m thankful to everyone who replies

you need to post the trace of the error you get so people can help you.
if you get an ImportError, you most probably need to re run bin/buildout to add the requirements you added to your package's to the buildout.

Develop: '/home/ananth/Plone/zinstance/src/'
Develop: '/home/ananth/Plone/zinstance/src/fincrm.contents'
Develop: '/home/ananth/Plone/zinstance/src/matplot.plone'
warning: no previously-included files matching '*.pyc' found anywhere in distribution
Installing instance.
/home/ananth/Plone/zinstance/local/lib/python2.7/site-packages/pkg_resources/ RuntimeWarning: You have iterated over the result of pkg_resources.parse_version. This is a legacy behavior which is inconsistent with the new version class introduced in setuptools 8.0. In most cases, conversion to a tuple is unnecessary. For comparison of versions, sort the Version instances directly. If you have another use case requiring the tuple, please file a bug with the setuptools project describing that need.
Getting distribution for 'matplotlib'.
error: Setup script exited with 
Matplotlib 3.0+ does not support Python 2.x, 3.0, 3.1, 3.2, 3.3, or 3.4.
Beginning with Matplotlib 3.0, Python 3.5 and above is required.

This may be due to an out of date pip.

Make sure you have pip >= 9.0.1.

An error occurred when trying to install matplotlib 3.0.2. Look above this message for any errors that were output by easy_install.
  Installing instance.
  Getting distribution for 'matplotlib'.
Error: Couldn't install: matplotlib 3.0.2
Matplotlib 3.0+ does not support Python 2.x, 3.0, 3.1, 3.2, 3.3, or 3.4.

is self-explaining with Plone running on Python 2.7

Either use an older version of matplotlib supporting Python 2.7 or consider switching to Plone 5.2 alpha which supportsPython 3.6+. Or use a different rendering idea what you want to visualize and how dependent you are on matplotlib.

I was just trying out

For numpy It posted a list of warning, Thanks for the reply