JPEGs uploaded to Plone are black-and-white and have lines through them

I have a Plone 5 installation running on AWS, installed with Bitnami's Plone image.

The system information is as follows:

  • Plone 5.0.7 (5017)
  • CMF 2.2.10
  • Zope 2.13.26
  • Python 2.7.13 (default, Jul 26 2017, 16:31:12) [GCC 4.3.0] PIL 1.1.7

We're having an issue - whenever a JPEG is uploaded (through the 'New Image' function, or as part of a post, regardless of the method), the JPEG is black-and-white and has vertical lines going through it, even if the original photo was full color.

The screenshot below is an example of what happens whenever we upload ANY JPEG:

Perhaps there is something wrong with the JPEG compression engine that Plone is using? The strange thing is that all other image formats work perfectly.

Has anyone experienced this issue before or does anybody have any clue how to go about solving it? I would just use use other image formats, but this is a community-based site and it's impractical for us to disallow the use of JPEGs.

Many thanks in advance for any assistance! I feel like someone else must have experienced this issue.

1 Like

Is this a new site? If not, what has changed recently in your buildout or on the system? Plone uses PIL, but that's an external thing.


@rockmancuso can you please confirm that it happens on as well? I have no b/w picture here at the moment.


Thanks for the response!

@tkimnguyen - This has actually been happening since the first day we installed the Plone instance (with Bitnami). We actually just tried launching a fresh installation of Plone (Bitnami) and we're experiencing the same issue.

@pbauer - Regarding the demo site, we tried uploading a JPEG, and it worked fine - no lines or anything through it, which is interesting...

Could this possibly be a Bitnami issue?

Thanks again for the help guys, it's MUCH appreciated!

1 Like

I don't know what the install method is for Bitnami, so perhaps it's using an old version of something or something else in the OS image it uses (again I have no idea how Bitnami works) is no longer compatible with the Plone install recipe.

Comparing the demo site you guys posted and the version that we're using, it appears the PIL is quite outdated. We're going to try updating it and seeing if that helps alleviate the issue.


  • Plone 5.1rc2 (5109)
  • CMF 2.2.12
  • Zope 2.13.26
  • Python 2.7.14 (default, Oct 9 2017, 22:27:46) [GCC 4.8.4]
  • PIL 4.3.0 (Pillow)

Our Site:

  • Plone 5.0.7 (5017)
  • CMF 2.2.10
  • Zope 2.13.26
  • Python 2.7.13 (default, Jul 26 2017, 16:31:12) [GCC 4.3.0]
  • PIL 1.1.7 (edited)

Many thanks for the assistance thus far :+1:

Maybe take a look at the Plone 5.0.8 and 5.0.9 pins, otherwise you'll be comparing what could be significantly different (5.1rc2)

I'd first try to pinn Pillow to a newer version (like 4.3.0). If that does not fix it I'd try to replicate the exact same versions/buildout on a different OS (like another Linux or MacOS). I think can only be PIllow/PIL or one of the underlying libraries (libjpeg)

1 Like

it seems that Bitnami really use PIL the original library, not the Plone fork Pillow.
I was not even imagining that Plone could use it.


the 1.1.7 is the most 'recent' (less ancient) version to download.

A vanilla 5.07 install on my computer has picked the 3.3 version of Pillow, a 5.1 Plone Pillow has picked 4.2.

It would be interesting to see what the buildout from Bitnami contains.

1 Like

Hey everybody, thank you so much for the great help - I wanted to let you all know that we solved this issue by upgrading Pillow to 4.2.1, we did that, ran a buildout and the issue was solved!

The responses are greatly appreciated, this is a great community full of people who are very willing to help, and I think that's awesome.

Thanks again!


1 Like

You nailed it, @pbauer :ok_hand:

Thanks again guys.

1 Like

We're glad to help! You made it easy by providing lots of context up front :slight_smile:

Now... will you tell us a bit more about this site? We'd love to hear what you're doing with it...

1 Like