Intro and current progress(plone install error docs)

:wave: Hello Plone Community!

I'm thrilled to join this vibrant community and contribute to the amazing projects being developed here. Allow me to introduce myself:

:man_technologist: About Me:
I'm Rohan a passionate developer with a focus on the MERN (MongoDB, Express.js, React.js, Node.js) stack. I've been deeply immersed in web development and I'm excited about the potential of open-source collaboration to create impactful solutions.

:star2: Contributions and Interests:
While I'm proficient in React.js, I'm also enthusiastic about exploring other technologies within the MERN stack and beyond. I believe in the power of continuous learning and collaboration, and I'm eager to contribute my skills and expertise to projects that align with my interests.

:rocket: Goals in the Community:
As a member of this community, my goal is to not only contribute code but also to engage with fellow developers, share knowledge, and foster a supportive environment for learning and growth. I'm keen to take part in discussions, offer assistance where needed, and collaborate on exciting initiatives.

:mag: Areas of Interest:
I'm particularly interested in plone is Volto development with react and would like to contribute in it. However, I'm also open to exploring new domains and expanding my skill set through diverse projects.

:mailbox: Get in Touch:
I'm looking forward to connecting with all of you! Feel free to reach out to me here and let's embark on this journey of open-source collaboration together.

Let's code, learn, and grow together!

Best regards,


  1. Currently following to understand and learn plone.
  2. I am successfully able to install plone in my local environment (ubuntu).

Problems occured till now
=> I was first trying to install plone from .
After successfully installing all dependencies when i tried to run final comment which is
pipx run cookiecutter gh:collective/cookiecutter-plone-starter

the error was ls-cs module however even after installing module error was same

After multiply try by installing and reinstalling each dependency i gave on this and went with installing method given which is
git clone GitHub - collective/training_buildout: Plone backend installation for the Mastering Plone Development Training backend .

It worked , backend and frontend both installed locally .
But i want to know the error with cookiecutter method in .

=> Done with plone6 development training

=> Now i am starting volto development training with react js.

Please read Why should I not upload images of code/data/errors? - Meta Stack Overflow.

Please use the search of the Community Forum by copy-pasting your error message into the search feature, and it will return one answer:

This is how all senior developers solve problems when the error message is not helpful: search for the error message first in the specific product support, then on Stack Overflow, and eventually search engines. We don't know anything, but we have essential research skills.


Interesting, thanks for sharing about 'Why should I not upload images of code/data/errors', I believe a lot of developers really need that. @stevepiercy