Internal links containing site name

I have a site with a URL for users (through varnish), let's call it and a URL for editing,

The problem is that when I create an internal link in TinyMCE on it generates the following when looking at the source, clicking on the HTML button:

<a class="internal-link" href="resolveuid/754739b9a00b082d13a450e072d7e6a1" target="_self" title="">Link Made in TinyMCE</a>

After saving it, it is:

<a class="internal-link" target="_self" href="" title="">Link Made in TinyMCE</a>

New pressing edit again the link is relative:

<a class="internal-link" href="page" target="_self" title="">Link Made in TinyMCE</a>

But when saving it, it stays both on and

This is obviously a problem, since I don't want normal users to go to

How do I change it, so the site name is not in the href (or so it is always and never

The site is using Plone 4.3.6.

since you have gotten no anwsers, I give you a suggestion about something I dont know much about:

• Can you hard code the site in /portal_url (in ZMI)

resolveuid links are only turned into proper links when they are viewed and will take into account the url that was used to access that page. If you view it with the proper url the link should be fine

That is an idea. However it doesn't seam to be possible to overwrite the portal_url tool from the zmi. I have tried deleting portal_url, renaming portal_url, and putting a method in the zmi named portal_url. All of these results in an error message.

The problem is that the link isn't converted. It is still showing the edit link on the non edit site (on the proper url).

We have lot of sites with backend/front-end URLs and we never experienced this problem on Plone 4.

You have something that is not working properly. Try to find what it is, for example disable JavaScript (so TinyMCE) and see if you still suffer this behavior.

The problem is in TinyMCE, somehow. If I turn off TinyMCE and edit the html-field, the links aren't converted. I have recently upgraded Plone from 4.3.3 to 4.3.6, but that didn't changed the behavior. Is it possible to reinstall TinyMCE only, and/or reset it to it's default settings within Plone?

I tried to reproduce your issue on Plone 4.3.6 without success.

  • If I add an internal link the view source from TinyMCE use the resolveuid: ok
  • after saving the HTML in the page display an absolute URL
  • accessing the same site from another domain display and HTML with the alternative URL

I fear you have some JavaScript issue that "break" TinyMCE when it try to reload the HTML of the page.
Are you using an official TinyMCE version? Are you using strange TinyMCE plugins?