Increase max file upload for WGSI during buildout

I have a local install of Plone 5.2 / Python 3. When trying to upload a 1.27GB file, the browser displays the error:

Request Entity Too Large
exceeds max_body of 1073741824 
(generated by waitress)

As a workaroud, I can modify parts/instance/etc/wsgi.ini directly by adding:

[server:main] 
max_request_body_size = ######

However, I'm looking for a solution via buildout settings. Looking through plone.recipe.zope2instance, the only thing I could think of so far is creating my own custom wsgi-ini-template.

Correct

Or provide a pull request for plone.recipe.zope2instance

Thanks for the responses!

Plone Foundation Code of Conduct