ImportError: No module named IResourceRegistry

Hello !
I tried to make the add on collective.geo available on my site and I'm getting this error

Traceback (innermost last):

Module ZPublisher.Publish, line 138, in publish
Module ZPublisher.mapply, line 77, in mapply
Module ZPublisher.Publish, line 48, in call_object
Module Products.CMFQuickInstallerTool.QuickInstallerTool, line 593, in installProducts
Module Products.CMFQuickInstallerTool.QuickInstallerTool, line 521, in installProduct
traceback_info: ('collective.geo.bundle',)
Module Products.GenericSetup.tool, line 365, in runAllImportStepsFromProfile
traceback_info: profile-collective.geo.bundle:default
Module Products.GenericSetup.tool, line 1119, in _runImportStepsFromContext
Module Products.GenericSetup.tool, line 1030, in _doRunImportStep
Module, line 49, in importRegistry
Module, line 94, in importDocument
Module, line 281, in importRecords
Module zope.dottedname.resolve, line 38, in resolve
ImportError: No module named IResourceRegistry

Any help to fix this please ?

You should tell us which version of Plone (and which version of collective.geo).

ā€¦ and maybe what you need it for, since if your versions are not compatible, there might be something else you can use.

Plone and collective.geo 2.3, I'm trying to have the same eggs of the production site for tests
Thank you for your feedback

Trouble is with collective.geo.mapwidget, it was updated for Plone 5 in sept 2015 and there was a release in 2016 without creating a Plone 4 branch, so I think you should try to pin it to 2.2. It's possible that similar problems exist with another parts of the collective.geo.bundle package.

Thank you, but I'm using collective.geo.bundle, do you think I should use another release too?

I don't know if buildout allows to pin the individual packages from the bundle while still using the bundle. You can try. Or you can forget the bundle and include the individual add-ons included in the bundle

  - collective.geo.behaviour
  - collective.geo.kml
  - collective.geo.contentlocations
  - collective.geo.mapwidget
  - collective.geo.geographer
  - collective.geo.settings
  - collective.geo.openlayers

and pin them appropriately in versions section of your buildout.cfg

Thank you, I will try this and let you know if it worked

I run into the same error with Plone 4.3.18. However, in my case, using collective.z3cform.colorpicker = 1.4 seems to fix this error.


eggs +=

collective.z3cform.colorpicker = 1.4

For the record, here are the screenshots.

1 Like