HTTP 404 from buildout on, but working using wget

I need to move an old Plone 4.1 installation to a new server.

I get this error, although the URL is correct and can be fetched using wget from the same system.

Any idea?

bin/buildout  -vvvv 
Error: Error downloading extends for URL HTTP Error 403: Forbidden

Maybe some proxy?


Maybe a misleading error message?

@zopyx Is your problem solved ? Which buildout version did you test ?

Unsolved. I tried zc.buildout 21.3 and 17.0. No difference. I tried the same buildout on a different host of mine, same result.

Does anyone know who is in charge of from the administration point of view? @dataflake perhaps?

There is a proxy in place on the server end: CloudFlare.

To make sure that's not the problem I changed the DNS settings for the host to use the straight IP of the server and not go through the CloudFlare proxy. The change may take a little while to propagate through DNS.

I just confirmed the DNS change fixes the buildout issue. The problem appears to be in how zc.buildout and CloudFlare interact on the HTTP request that fetches the extends URLs.

Thanks Jens @dataflake! Problem solved (for now).