Help please, recent new plone 5 instances not working behind my mod-rewrite apache proxy?

I run a number of plone sites operating as separate users on a small server running ubuntu 14.04 and Apache 2.4. Because I have to maintain only one IP address and can only have outside access on port 80, I proxy each of these sites behind Apache using the rewrite_mod. This has worked well for years and worked fine for a 5.0.4 site I started new in June 2016. Now, however, the latest new site I tried to put up responds slowly or not at all behind the proxy. I thought I might be overloading the server, but I shut down all my other sites to no avail. As the 5.0.4 site I started in June installed its own python, I tried insisting on building the python as well, but it had no effect. I have used the same installer for both sites.

I am quite mystified. Any ideas what I could look at? Force some other static libraries (libxml?)? Could it be updates to things like readline? My site from June is still running fine.

Thanks for thoughts.

There is not much information here in order to help you except wild guessing...either you procide much better solid information about your case or get in touch with a Plone professional.


To put it in a slightly nicer way. There are a lot of possible reasons and not much information. For example, what happens when you connect direct to the zope port? Does a single request start and never return? Whats the cpu and ram doing? whats your bin/instance look like? What method did you use to install it?

Try fist to make sure your Plone installation runs fine. You can check it with a local browser like lynx or links2 on the CLI, just open localhost:yourport/YourPloneID and check if the side response fine.
Also start the instance in foreground with ./bin/client1 fg or ./bin/instance fg depending how your instances are named and check for error and warnings.

Thanks for the feedback folks. For those of you who wanted more information, I left it out because there really isn't anything. I have an account on my server that I create standalone installations of plone using ./ standalone --target="path" for testing. I do everything locally and then for final testing before moving the installation to its own account I set up proxying through Apache. Suddenly, the new test setups stopped responding when put behind Apache. I could still access them fine locally, and older installations set up this way still worked.

I've turned on proxy tracing and looked through the Apache logs. I get no errors when running the instances that are giving problems in the foreground. I am still mystified.

One Clue
I created a new user and installed another instance in that user. The installation in the new user account works fine behind the proxy. I assume this means that something about the way Plone gets setup within an account is messed up in the one I was using for testing. Is there somewhere that an older Plone installation might have left something that would impact newer ones? I thought everything was self-contained within the specified target folder. I would like to get my original testing account working again. But my problem is solved by the creation of this new account.


Almost fixed (hints for anybody else who runs into this)
The sites on the old account are now usable. I'm still having some issues with some of the paths to javascript files not being completely translated by virtualhostmonster (most work, but ace-editor for editing the dexterity XML is not working).

I did two things that both seemed to be necessary:

  1. I deleted all the rewrite rules to sites that didn't work making sure to completely clear the line of code where each was. I then retyped the rewrite rules (actually I copied a working one and edited it). I kept a copy of the deleted code. They look identical, but maybe there was a non-printing character.
  2. I added a blank line immediately below the last rewrite rule in the chain.

This makes things much better, but not perfect. However, it does look like the problem is primarily associated with how Apache 2.4 reads the virtualhost .conf file.