Got an error with plone 5.0.5 and 5.0.6 for folder_contents

Hi,
I encounter a problem with folder_contents request for those plone versions., but only in the context of virtual hosting behind an apache server. For 5.0.4 the request is ok.

After having read the issue https://github.com/plone/plone.app.content/issues/77, I made tests with previous versions of plone.app.content. It's ok for version 3.0.20 but I got the error for more recent versions.

The tests where made on a fresh (without any other module) french plone site (plone.app.multilingual not activated).

Below, the error :

2016-10-18T09:16:53 ERROR Zope.SiteErrorLog 1476775013.620.558638731005 https://...../essai/folder_contents
Traceback (innermost last):
  Module ZPublisher.Publish, line 138, in publish
  Module ZPublisher.mapply, line 77, in mapply
  Module ZPublisher.Publish, line 48, in call_object
  Module plone.app.content.browser.contents, line 275, in __call__
  Module plone.app.content.browser.contents, line 233, in get_options
  Module plone.app.content.browser.contents, line 65, in get_top_site_from_url
  Module ZPublisher.HTTPRequest, line 280, in physicalPathFromURL
ValueError: Url does not match virtual hosting context 

And the rewrite rule

RewriteRule ^/essai($|/.*) \
http://172.16.7.11:8101/VirtualHostBase/https/%{SERVER_NAME}:443/Plone/VirtualHostRoot/_vh_essai$1 [L,P]

Any idea ?
Thanks in advance,
Eric

Maybe it was fixed here:


Thank you, I haven't seen this (un)release...

On the test I just did in the same conditions as before, it seems OK. I hope that 3.3.2 will be released soon.