Feedback on Plone 5 Pre-Release Versions

This space is for site administrators, builders, content creators, designers, and yes, even Plone admirers from afar!

Try the pre-releases and share what you find so problems can be addressed before the Plone 5 is released into the wild. From migration and integration issues to broken Add-ons and problems with usability or content, all constructive feedback is welcome!

One of the big improvements for me would be having a theming control panel. I would love to be able to edit and tweak the default theme of Plone 5. There should be some updates to the history/versioning for custom dexterity types & regular types in general. The custom content types does not keep track of edits just changes to the state of the item. There needs to be fixes to the key manager when you login. Those are just a few of the improvements I have ran into working with it for the last three weeks. I love Plone 5 though. It has great potential and is already awesome.

  • We already do a have a theming control panel. Are there improvements to it that you'd like to see done?
  • You should be able to enable versioning on your custom dexterity types by going to the Types control panel I think. It'd be nice to have this integrated into the dexterity types variant though.
  • can you be more specific on "fixes to the key manager when you login"?

I think what he's saying is that plone 5 should ship with a active diazo
theme you can tweak. Rather than just the base theme. I think that would be
a really good idea.

The new plone 5 theme is diazo-based: https://github.com/plone/plonetheme.barceloneta

Hmm. right you are.

In that case perhaps our theme editor is not so intuitive? Maybe we need to guide first time users a little more?

Theme Control Panel

  • This is what copying the barceloneta theme and editing it looks like: https://db.tt/JOjM0rGc
  • All of the css files are missing.
  • I would love to see how to change things like the logo, and remove items off of the side control panel. Basically, I love how in chrome I can edit the theme and take things away and fix css but there is no way to save these changes to the theme.
  • The control panel needs some theming that is permeant not a clean theme
  • I would just like to have more control over the theming & css. I have no clue of how to add a new theme locally to load up as default. This way others checking out the project can get the same theme.

History

  • Even if you enable versioning it does not show edits for custom content types.
  • You can not compare to version of default content types
  • The following ensues: http://pastie.org/9281065 & https://db.tt/7rzoIr0i
  • A bunch of the css styling doesn't load for the history pop up either

Thanks for getting those bug reports in. Maybe we can get some people to work on them during the midwest symposium sprints coming up next week.

1 Like

I wish I could make it there! It would be awesome to meet people in the community and help out on the sprint. Vangheem, thank you for helping me so much so far. I am always on the IRC Chat.

One feature that I really want to work which currently doesn't is the collapsing of the toolbar. Calling All Adventurers states that it works: "New toolbar that stays outside the theme (can be positioned to top, bottom, or sides) and is collapsible". However, after a clean install the collapsible feature does not work.

ugh, I was supposed to delete part of that. Sorry for the confusion. I'll update the article now.

It should read, "New toolbar that stays outside the theme and can be repositioned."

1 Like

I got excited for a second because I thought it was fixed. :smile:

Hello

I'm not sure about where to post bugs ( forget about trac ? )

I just installed plone5a from unified installer
I notice that going to site preferences and clicking on 'Themes' ( URL /Plone/@@theming-controlpanel ) leads to an error

Voilà

Fred


Traceback (innermost last):

Module ZPublisher.Publish, line 138, in publish
Module ZPublisher.mapply, line 77, in mapply
Module ZPublisher.Publish, line 48, in call_object
Module plone.app.theming.browser.controlpanel, line 51, in call
Module Products.Five.browser.pagetemplatefile, line 125, in call
Module Products.Five.browser.pagetemplatefile, line 59, in call
Module zope.pagetemplate.pagetemplate, line 132, in pt_render
Module five.pt.engine, line 93, in call
Module z3c.pt.pagetemplate, line 163, in render
Module chameleon.zpt.template, line 257, in render
Module chameleon.template, line 190, in render
Module chameleon.template, line 172, in render
Module a8416b682498838c0c35f59c9472d4e283b9d4a1.py, line 4833, in render
Module 180b2e639fa8d8ce93e2b6f3f3050bb41e988dd5.py, line 1202, in render_master
Module 180b2e639fa8d8ce93e2b6f3f3050bb41e988dd5.py, line 460, in render_content
Module a8416b682498838c0c35f59c9472d4e283b9d4a1.py, line 2996, in __fill_main
Module plone.app.controlpanel.skins, line 141, in get_use_popups
AttributeError: 'NoneType' object has no attribute 'getEnabled' - Expression: "python:request.get('usePopups', view.skinsSettings.use_popups)" - Filename: ... .2.0-py2.7.egg/plone/app/theming/browser/controlpanel.pt - Location: (529:45) - Source: ... python:request.get('usePopups', view.skinsSettings.use_popups) ... ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ - Arguments: repeat: {...} (0) template: <ViewPageTemplateFile - at 0xbbb336c> views: <ViewMapper - at 0xc7206cc> modules: <instance - at 0x93c782c> args: <tuple - at 0xb759802cL> here: <ImplicitAcquisitionWrapper Plone at 0xc799b6c> user: <ImplicitAcquisitionWrapper - at 0xd51e52c> nothing: <NoneType - at 0x81bf64c> container: <ImplicitAcquisitionWrapper Plone at 0xc799b6c> request: <instance - at 0xb50318c> wrapped_repeat: <SafeMapping - at 0xd3b5d74> traverse_subpath: <list - at 0xc7204ec> default: <object - at 0xb75b7808L> loop: {...} (2) context: <ImplicitAcquisitionWrapper Plone at 0xc799b6c> view: <SimpleViewClass from /opt/P5a2/buildout-cache/eggs/plone.app.theming-1.2.0-py2.7.egg/plone/app/theming/browser/controlpanel.pt theming-controlpanel at 0xb50326c> translate: <function translate at 0xc3b4f44> root: <ImplicitAcquisitionWrapper Zope at 0xb797c5c> options: {...} (0) target_language: <NoneType - at 0x81bf64c>

They have fixed that in the latest control panel. You can require the latest version in your build out if you want it to work. The theming control panel has no formatting so theres that also. plone.app.controlpanel

buildout.cfg

[sources]
plone.app.controlpanel = git https://github.com/plone/plone.app.controlpanel.git

Thanks works fine ( no need to update version.cfg if using mr.devloper )

Cheers

Fred

1 Like

Awesome, I ran into the same problem when I was working with it. I showed the people who managed it and they fixed it.

I'm having a problem trying to upgrade a 4.3.2 site to 5.0a2, I think maybe part of the upgrade process isn't finished? :smile:
From a thread on the plone users mailing list :

I just created a new clean plone 4.3.2
build, created a single site in it, totally plain, then copied the var
structure into a plain 5.0a2 build - and it's still failing to upgrade.

Both instances running on CentOS 5.x, built with the following arguments :

./install.sh --target=/plone/[blah] --build-python --static-lxml standalone

So maybe it's not an issue with subskins, but something with the move
from 4.3.2 to 5.0a2?

There's nothing terribly interesting in the instance.log file, but it is
suggesting that it's not finishing for a more subtle reason? :

2014-07-10T22:42:17 INFO plone.app.upgrade Ran upgrade step: Run
to50alpha1 upgrade profile

2014-07-10T22:42:17 INFO plone.app.upgrade Ran upgrade step: Run
to50alpha1 upgrade profile

2014-07-10T22:42:17 INFO plone.app.upgrade Ran upgrade step: Use
lowercase for email login

2014-07-10T22:42:17 INFO plone.app.upgrade End of upgrade path,
migration has finished

2014-07-10T22:42:17 ERROR plone.app.upgrade The upgrade path did NOT
reach current version

2014-07-10T22:42:17 ERROR plone.app.upgrade Migration has failed

The version I have is 5.0a2, not alpha1 - maybe an omission in the
upgrade process for Plone itself?

Where would I check this?

Carl

I have the same issue as mentioned above. I've added that line to my buildout and re-ran the buildout, and instance. I still have that same issue... any help would be great. I would love to start diving into Plone 5's theming options.

trevorgrantstua are you using mr developer?

Plone Foundation Code of Conduct