Every resource Plone webpage tries to load from localhost

I’m new in Plone. Try to deploy it on my Debian 10 server.

I’ve deployed ZEO Server and clients daemons, so when try to access to client locally I see a Plone first webpage – something like “Add new site …”. It doesn’t work properly (Internal Server Error when I add a new site (http error 500) ), but at least, I can see a normal page, anyway …

When I access to this (first) webpage from internet remote PC, every resource on webpage tries to load from locacalhost (127.0.0.1 ): .css, images, icons – so, actually, nothing was loaded. (See an image below)

Any advice. What is wrong?
Thanks in advance.

Here are some things that describe the situation.

<VirtualHost *:80>
    ServerName  www.site.io
    ServerAlias site.io
#    ServerAdmin admin@site.io
    ServerSignature On

    AllowEncodedSlashes NoDecode

    LogFormat       combined
    TransferLog     /var/log/apache2/www.site.io.log

    <IfModule mod_proxy.c>
        ProxyVia On

        # prevent the webserver from being used as proxy
        <LocationMatch "^[^/]">
            Deny from all
        </LocationMatch>
    </IfModule>

    # Balance load between 2 ZEO front-ends
    <Proxy balancer://lbzeo>
        BalancerMember http://127.0.0.1:10080/ route=1
        BalancerMember http://127.0.0.1:10081/ route=2
        ProxySet lbmethod=bybusyness  stickysession=ROUTEID
    </Proxy>

    # Note: You might want to disable this URL of being public
    # as it can be used to access Apache live settings
    <Location /balancer-manager>
        SetHandler balancer-manager
        Order Deny,Allow
        # Your trusted IP addresses
        Allow from 127.0.0.1
    </Location>
    
#    <Location /admin>
#	       ProxyPass        balancer://lbzeo stickysession=ROUTEID
#    </Location>

    ProxyPass /balancer-manager !
    ProxyPass             /admin balancer://lbzeo stickysession=ROUTEID
    ProxyPassReverse      /admin balancer://lbzeo stickysession=ROUTEID
    
    ## Disk cache configuration, if you really must use Apache for caching
    #CacheEnable disk /
    ## Must point to www-data writable directly which depends on OS
    #CacheRoot "/store/cache/plone_site.io"
    #CacheLastModifiedFactor 0.1
    #CacheIgnoreHeaders Set-Cookie

    # Debug header flags all requests coming from this server
    #Header append X-vxlab yes
    Header add Set-Cookie "ROUTEID=.%{BALANCER_WORKER_ROUTE}e; path=/" env=BALANCER_ROUTE_CHANGED

</VirtualHost>

You need a RewriteRule for the virtual host

https://docs.plone.org/manage/deploying/front-end/apache.html

Plone Foundation Code of Conduct