Error while upgrading from plone 3.3.5 to 4.3.9

Hi! We are in the process of migrating our site from plone 3.3.5 to 4.3.9. After copying our existing source code and database files(data.fs, catalog.fs and filestorage) in a new installation of plone 4, when we visit the "plone is up and running" home page in the browser, a message appears saying "your site configuration is outdated and needs to be updated". When we click the upgrade button(both with and without dry run checkbox checked), the upgrade process prints following error statements but carries on finishing:

ERROR GenericSetup Step kupu-setup has an invalid import handler

ERROR GenericSetup Step kss_mimetype has an invalid import handler

ERROR PortalTransforms Cannot register transform html-to-captioned (ImportError), using BrokenTransform: Error No module named html2captioned

When we revisit the home page in browser, it still displays the same message saying your site needs to be upgraded.

What could be the issue here? Any help would be appreciated.

These three errors should be no problem. The first two are from packages (kupu and kss) that are no longer needed in Plone 4.3. They will be cleaned up during the upgrade. The third is probably fixable by installing the html2captioned utility. Ah, that is actually from the removed kupu. This might get cleaned up during the upgrade as well. But this is not what is causing the real problem.

You have tried both with and without the dry run option. To save the changes, you need to run it without dry run.
If there is a real problem, it should say something like 'the upgrade did not reach the latest version'.

I would then expect details to be visible in zeoclient.log or instance.log. Is anything there?
Also, an error may be visible when you scroll further down the page.

Thanks for getting back Maurits, We did not get any error/exception saying "the upgrade did not reach latest version". Following are the dropbox links to the client event.log file and screenshots of upgrade screen:

Regarding the error being visible upon scrolling further down the page, we get a network timeout error message in the browser as the upgrade activity takes some time, although the activity keeps running as seen from the log file.

When you have a web server, like nginx or Apache, in front of Plone, which is highly recommended, this web server usually gives up when a request takes more than a minute. Since an upgrade can take a lot longer, it may help if you connect to the Plone instance port directly. You probably need to use ssh port forwarding for this.

But like you see, the upgrade continues anyway. So you can follow the zeoclient log to see what it is doing and if it is really finished.

The last line in your log file that I see from the migration is 'Migrating static text portlets'. After that, no lines appear, until 14 minutes later the server is restarted. That is this line in the code:

The code here goes through your entire site, which could take long if you have a lot of data. And this might take up a lot of memory. If you have something like memmon installed that kills your zeoclient if it takes up too much memory, you may want to switch that off.

If you have no static text portlets, you could skip this part of the code by commenting it out. Maybe remove them and recreate them later if there are just one or two of them.

Hi Mauritz,

Once again thanks for the help. We followed your approach of commenting out the code that migrates static text portlets. This time, the upgrade activity is failing explicitly with the following error message:

u'No blob file at

We followed the approaches mentioned in the link like recopying blobstorage, creating a fix-blobs admin view to cleanup bad BLOB content but are still stuck at the same error.

If you're sure you copied the entire blobstorage I don't see how you can be running into this error.

You could copy that exact missing blob from the original site?