Error while installing the unified installer HELP needed

I tried installing the unified installer version 5.2.6 on my ubuntu OS and failed consistently. I tried to build python and failed there as well.
OS: ubuntu 22.04 LTS
Unified installer version: 5.2.6
Python: 3.8

It shows the following error:

bhuvan@bhuvan:~/Downloads/Plone-5.2.6-UnifiedInstaller-1.0$ ./install.sh

Testing /usr/bin/python3.8 for Zope/Plone requirements....
Traceback (most recent call last):
File "/home/bhuvan/Downloads/Plone-5.2.6-UnifiedInstaller-1.0/helper_scripts/checkPython.py", line 5, in
from distutils.sysconfig import get_python_inc
ModuleNotFoundError: No module named 'distutils.sysconfig'

/usr/bin/python3.8 does not meet the requirements for Zope/Plone.

Please do one of the following:

  1. Install python3.8 or python3.6+ as a system dev package;
  2. Use --with-python=... option to point the installer to a useable python.

Please help me out

Looks like distutils is not installed on your machine. Try sudo apt-get install python-distutils

Plone Foundation Code of Conduct