Error starting Plone server

As recommened on S.O. I post this question here

When I ./bin/instance start server I get

  [root@eprssrv08 zinstance]# ./bin/instance start
    . Unlinking stale socket /esmart/Plone/zinstance/var/instance/zopectlsock; sleep 1
    No handlers could be found for logger "root"
    daemon process started, pid=2657

but Plone server is not reachable. What's the meaning of this?

by the way this happens every time, after the phisical server where shutted down without stopping Plone correctly.

  • the instance runs on port 80
  • with ./bin/instance fg the instance runs well!!

I "solved" making chmod 777 on "zinstance" directory (??)

You don't say how you set up the Plone installation, e.g. unified installer? The unified installer would create a plone_buildout user and a plone_daemon user (both belonging to plone_group) and would ensure the correct ownership and permissions of directories and files. Certainly you should not run Plone as root! And... it's insane to give 777 to that directory :slight_smile:

Had an issue like this today and came across this. Just to put in my 2 cents and make sure no-one is misled by the idea of setting 777 permissions as a solution.
Setting a file as 777 is never a good idea, it makes that file or directory writeable by ANYONE and ANY process.
If your server is ever compromised, which I hope never happens, then there will be one less barrier between the attacker and your files and folders. In fact, your server need not be compromised, someone just needs to figure out a way to pass the "right" instruction to your server so that the server itself does something bad like delete all your data.

As @tkimnguyen has suggested, your setup is configured to run as a different user (plone_daemon). The solution is to launch everything as the plone_daemon

sudo -u plone_daemon bin/plonectl start

See the plone docs on this here:

1 Like

'Writable by anyone' is the bigger issue there.

Thanks @Rotonen,
Fixed my response accordingly.