Error in theme barceloneta

Hello! I am new to the community and recently started to develop in Plone. I was testing some versions and when I tried to reinstall version 5.2 the following problem appeared:

  File "/home/rafa/Plone5.1/buildout-cache/eggs/diazo-1.2.8-py2.7.egg/diazo/rules.py", line 293, in process_rules
    rules_doc = etree.parse(rules, parser=rules_parser)
  File "src/lxml/etree.pyx", line 3444, in lxml.etree.parse (src/lxml/etree.c:83185)
  File "src/lxml/parser.pxi", line 1834, in lxml.etree._parseDocument (src/lxml/etree.c:120757)
  File "src/lxml/parser.pxi", line 1860, in lxml.etree._parseDocumentFromURL (src/lxml/etree.c:121104)
  File "src/lxml/parser.pxi", line 1764, in lxml.etree._parseDocFromFile (src/lxml/etree.c:120012)
  File "src/lxml/parser.pxi", line 1161, in lxml.etree._BaseParser._parseDocFromFile (src/lxml/etree.c:114561)
  File "src/lxml/parser.pxi", line 598, in lxml.etree._ParserContext._handleParseResultDoc (src/lxml/etree.c:107738)
  File "src/lxml/parser.pxi", line 709, in lxml.etree._handleParseResult (src/lxml/etree.c:109447)
  File "src/lxml/parser.pxi", line 636, in lxml.etree._raiseParseError (src/lxml/etree.c:108258)
IOError: Error reading file '/++theme++barceloneta/rules.xml': failed to load external entity "/++theme++barceloneta/rules.xml"

Plone can run on my computer, but I can't edit anything anymore. The interface also got a little unconfigured.

I would like to know what may have caused this problem and how I can solve it. I am trying to fix it for days but this problem persists and I cannot continue my studies in Plone. I've tried to install other versions but nothing worked.

If anyone can help me, I would be grateful. And if you can, have a little patience with me, I'm a newbie. :pray: :pray: :pray:

I would start by adding a new Plone site on the same Zope and see if you got the same problem.

Unless you have added a lot of content it is probably faster to copy / paste this to the new site. You can do this by going to http://myserver:8080/Plone/manage_main and copy the folders / pages and then just go to your new site and paste them.

Hi,

we recently encounter same problem, this was due to fact that "Anonymous" did not have the "Access contents information" permission.

Even if current user has the permission. But when logged in as a Zope Manager, then the error disappeared...

Hope this can help...

Gauthier

1 Like