Error: Error downloading extends for URL

I'm trying to run buildout for a Plone site, but I keep on getting this error:

While:
Initializing.
Error: Error downloading extends for URL http://dist.plone.org/release/4.3.15/versions.cfg: ('http error', 400, 'Bad Request', <httplib.HTTPMessage instance at 0xb6b957ec>)

This is my code under extends:
extends =
base.cfg
http://dist.plone.org/release/4.3.15/versions.cfg

I opened the version.cfg url and its still there.

I'm using Plone 4.3 and I'm behind a proxy. I'm not sure if this is the appropriate place to ask this question, but my OS is Xubuntu 14.0 in a Virtual Machine (VMware Workstation 14 Pro). This issue wasn't happening earlier. I reverted to a snapshot that was working and am I oddly getting the same error. I have apt.conf set with "Acquire" 'statements' and I have export https_proxy and http_proxy set.

Is this an issue with the network I'm in or was there a change made to http://dist.plone.org/release/4.3.15/versions.cfg ?

I have another virtual machine setup with xubuntu 16.04 with a Plone 5.1 instance where buildout is working correctly with the same proxy settings. The network settings on the virtual machine have been set to "bridged connection", which I also tried with the VM with Plone 4.3.

dist.plone.org can also be reached via https. Maybe that works for you?
The admins team is doing some changes to the dist.plone.org machine these weeks, so possibly there may be temporary problems.

Plone Foundation Code of Conduct