Error @@bootstrapview

Hi guys!

The following error appears when I try to enter the buildout and plone :

AttributeError ( ' @@ bootstrapview ' ) ( Also , The Following error occurred while Attempting to render the standard error message , please see the event log for full details : @@ bootstrapview )

Has anyone seen this error or similar , and could help me ?

Wild guess (again): you have added a theme for Plone 4 to your Plone 5 buildout.
Remove 'some.theme' from you buildout.cfg and rerun bin/buildout

I'm using Plone 4.3.3 . But even then I did what you indicated and did not work, the error continues!

Never heard of @@bootstrapview. A google search brings up: which is a custom theme from eu de web.
Can you give us more context, like how you installed Plone, which addons you use, your buildout configuration file, steps to reproduce?

About this file you found on google, I had seen him before, made ​​some changes based on it and the error went on. When I installed Plone used this tutorial:

About addons, the only package I installed was the 1.8.0. This error appeared in a weird way, I was creating templates as I do every day here at work, I do buildolt , and he appeared! Undid all the alterations he had made, but the error continues!

I apologize for my English, I learned a long time !

Below is my configuration file buildolt.cfg


extends =

find-links +=

effective-user = ubuntu

buildout-user = ubuntu

need-sudo = no

eggs =

zcml =

develop =




deprecation-warnings = off

verbose-security = off

parts =

<= instance_base
recipe = plone.recipe.zope2instance
http-address = 8080

setuptools = 0.7.2
zc.buildout = 2.2.1
ZopeSkel = 2.21.2
Cheetah = 2.2.1
Products.DocFinderTab = 1.0.5
buildout.sanitycheck = 1.0b1
collective.recipe.backup = 2.17
plone.recipe.unifiedinstaller = 4.3.1
zopeskel.dexterity =
zopeskel.diazotheme = 1.1

This is probably the guilty for bringing up whichever dependency that implements @@bootstrapview. Look inside of it and of the packages listed in its

Yes, it's the same sistem.kabum which is giving problem. I send my file.

from setuptools import setup, find_packages
import os

version = '1.0'

long_description=open("README.txt").read() + "\n" +
open(os.path.join("docs", "HISTORY.txt")).read(),
# Get more strings from
"Framework :: Plone",
"Programming Language :: Python",
"Topic :: Software Development :: Libraries :: Python Modules",
'' ,
' [grok]',
'plone.namedfile [blobs]',
# -- Entry points: --
target = plone
# The next two lines may be deleted after you no longer need
# addcontent support from paster and before you distribute
# your package.
#paster_plugins = ["ZopeSkel"],


So sistema.kabum seems to be your policy package, i.e. the one that contains your project's specific code, including dependencies. I'd guess plonetheme.bootstrap is culprit (for not providing the @@bootstrapview attribute). Try isolating it.

When do you get the error msg? When you run instance? Could you please post FULL traceback (error msg) as seen in the log files? It's difficult to help otherwise.

Yes, I run the instance. The error appears when I try to install the package sistema.kabum , it starts the installation process and the error does not let you finish installing . I tried to buildolt without plonetheme.bootstrap and also did not work! The following is the complete error message.

 - __traceback_info__: ([], '@@bootstrapview')
AttributeError: @@bootstrapview
2016-05-18 14:52:03 ERROR root Exception while rendering an error message
Traceback (most recent call last):
  File "/home/ubuntu/Plone/buildout-cache/eggs/Zope2-2.13.24-py2.7.egg/OFS/", line 242, in raise_standardErrorMessage
v = s(**kwargs)
  File "/home/ubuntu/Plone/buildout-cache/eggs/Products.CMFCore-2.2.9-py2.7.egg/Products/CMFCore/", line 127, in __call__
return Script.__call__(self, *args, **kw)
  File "/home/ubuntu/Plone/buildout-cache/eggs/Zope2-2.13.24-py2.7.egg/Shared/DC/Scripts/", line 322, in __call__
return self._bindAndExec(args, kw, None)
  File "/home/ubuntu/Plone/buildout-cache/eggs/Zope2-2.13.24-py2.7.egg/Shared/DC/Scripts/", line 359, in _bindAndExec
return self._exec(bound_data, args, kw)
  File "/home/ubuntu/Plone/buildout-cache/eggs/Products.PythonScripts-2.13.2-py2.7.egg/Products/PythonScripts/", line 344, in _exec
result = f(*args, **kw)
  File "Script (Python)", line 35, in standard_error_message
  File "/home/ubuntu/Plone/buildout-cache/eggs/Zope2-2.13.24-py2.7.egg/Shared/DC/Scripts/", line 322, in __call__
return self._bindAndExec(args, kw, None)
  File "/home/ubuntu/Plone/buildout-cache/eggs/Zope2-2.13.24-py2.7.egg/Shared/DC/Scripts/", line 359, in _bindAndExec
return self._exec(bound_data, args, kw)
  File "/home/ubuntu/Plone/buildout-cache/eggs/Products.CMFCore-2.2.9-py2.7.egg/Products/CMFCore/", line 237, in _exec
result = self.pt_render(extra_context=bound_names)
  File "/home/ubuntu/Plone/buildout-cache/eggs/Products.CMFCore-2.2.9-py2.7.egg/Products/CMFCore/", line 177, in pt_render
self, source, extra_context
  File "/home/ubuntu/Plone/buildout-cache/eggs/Zope2-2.13.24-py2.7.egg/Products/PageTemplates/", line 87, in pt_render
  File "/home/ubuntu/Plone/buildout-cache/eggs/zope.pagetemplate-3.6.3-py2.7.egg/zope/pagetemplate/", line 132, in pt_render
strictinsert=0, sourceAnnotations=sourceAnnotations
  File "/home/ubuntu/Plone/buildout-cache/eggs/zope.pagetemplate-3.6.3-py2.7.egg/zope/pagetemplate/", line 240, in __call__
  File "/home/ubuntu/Plone/buildout-cache/eggs/zope.tal-3.5.2-py2.7.egg/zope/tal/", line 271, in __call__
  File "/home/ubuntu/Plone/buildout-cache/eggs/zope.tal-3.5.2-py2.7.egg/zope/tal/", line 343, in interpret
handlers[opcode](self, args)
  File "/home/ubuntu/Plone/buildout-cache/eggs/zope.tal-3.5.2-py2.7.egg/zope/tal/", line 888, in do_useMacro
  File "/home/ubuntu/Plone/buildout-cache/eggs/zope.tal-3.5.2-py2.7.egg/zope/tal/", line 343, in interpret
handlers[opcode](self, args)
  File "/home/ubuntu/Plone/buildout-cache/eggs/zope.tal-3.5.2-py2.7.egg/zope/tal/", line 533, in do_optTag_tal
  File "/home/ubuntu/Plone/buildout-cache/eggs/zope.tal-3.5.2-py2.7.egg/zope/tal/", line 518, in do_optTag
return self.no_tag(start, program)
  File "/home/ubuntu/Plone/buildout-cache/eggs/zope.tal-3.5.2-py2.7.egg/zope/tal/", line 513, in no_tag
  File "/home/ubuntu/Plone/buildout-cache/eggs/zope.tal-3.5.2-py2.7.egg/zope/tal/", line 343, in interpret
handlers[opcode](self, args)
  File "/home/ubuntu/Plone/buildout-cache/eggs/zope.tal-3.5.2-py2.7.egg/zope/tal/", line 583, in do_setLocal_tal
self.engine.setLocal(name, self.engine.evaluateValue(expr))
  File "/home/ubuntu/Plone/buildout-cache/eggs/zope.tales-3.5.3-py2.7.egg/zope/tales/", line 696, in evaluate
return expression(self)
  File "/home/ubuntu/Plone/buildout-cache/eggs/zope.tales-3.5.3-py2.7.egg/zope/tales/", line 217, in __call__
return self._eval(econtext)
  File "/home/ubuntu/Plone/buildout-cache/eggs/Zope2-2.13.24-py2.7.egg/Products/PageTemplates/", line 147, in _eval
ob = self._subexprs[-1](econtext)
  File "/home/ubuntu/Plone/buildout-cache/eggs/zope.tales-3.5.3-py2.7.egg/zope/tales/", line 124, in _eval
ob = self._traverser(ob, element, econtext)
  File "/home/ubuntu/Plone/buildout-cache/eggs/Zope2-2.13.24-py2.7.egg/Products/PageTemplates/", line 74, in boboAwareZopeTraverse
object = object.restrictedTraverse(name)
  File "/home/ubuntu/Plone/buildout-cache/eggs/Zope2-2.13.24-py2.7.egg/OFS/", line 317, in restrictedTraverse
return self.unrestrictedTraverse(path, default, restricted=True)
  File "/home/ubuntu/Plone/buildout-cache/eggs/Zope2-2.13.24-py2.7.egg/OFS/", line 300, in unrestrictedTraverse
raise e
AttributeError: @@bootstrapview

Where and how did you remove plonetheme.bootstrap?

I commented the line where it was , the file, redid buildolt and did not work

I guess now you should grep for the view name and identify/debug why it's not being made available. Maybe the buildout.cfg you're using doesn't bring all the same package versions as the production environment one does. Maybe they're running different Plone versions and plonetheme.bootstrap or some other dependency has compatibility issues. Could you share the entire source code you're using?

yes , I can email you ?

It's better if you share it publicly so more people can help. But you can send me a private msg if you prefer.