Dexterity webdav option appears to have a problem

I created a Dexterity content type and selected the behavior: "Locking support for dexterity".
I successfully created a content type. When I tried to edit I got an error. when I unchecked the behavior, editing worked fine.

I will post this as a bug in a few days unless I hear from someone showing me the cause.

I got this error:

Traceback (innermost last):
Module ZPublisher.Publish, line 138, in publish
Module ZPublisher.mapply, line 77, in mapply
Module ZPublisher.Publish, line 48, in call_object
Module z3c.form.form, line 218, in call
Module z3c.form.form, line 213, in update
Module, line 21, in execute
Module z3c.form.action, line 98, in execute
Module z3c.form.button, line 315, in call
Module z3c.form.button, line 170, in call
Module, line 78, in handle_delete
Module plone.dexterity.content, line 707, in manage_delObjects
Module OFS.ObjectManager, line 536, in manage_delObjects
ResourceLockedError: Object "propose-a-booster-club" is locked via WebDAV

@rileydog I have never seen this error in my life until now.

I have another test site, I'll try it there.

Hi, I just got this error when trying to delete a DX Collection

The solution was simple (after a bit of searching & thought)

I realised I had left the object I wanted to delete without cancelling an edit.

So I Edited the object again, Cancelled it properly, and then Deleted with no problem.


1 Like

Iirc this is already fixed in 5.1.

Thanks A lot for this.. This works perfectly. was having the same error.