Development of the project using docker

I have set up a Plone demo using Docker on my Mac, but I'm experiencing an issue where any modifications made to the local code do not appear to take effect on the local server.

Can you say what you tried and what happened in a lot more detail? There are ways to make this work, but it may or may not be expected to work depending on how you are using Docker.

I used the command docker-compose up

What is in your docker-compose.yml file? There are many ways to set up Plone and we can't read your mind about which one you tried.

I tried docker run --name plone6-backend -e SITE=Plone -e CORS_ALLOW_ORIGIN='*' -d -p 8080:8080 plone/plone-backend:6.0 for backend and docker run --name plone6-frontend --link plone6-backend:backend -e RAZZLE_API_PATH=http://localhost:8080/Plone -e RAZZLE_INTERNAL_API_PATH=http://backend:8080/Plone -d -p 3000:3000 plone/plone-frontend:latest for frontend.

This way of running Plone is only good for a quick demo of the released software. It does not set you up for doing development of your own site on top of Plone. Instead, follow the instructions at Install Plone from its packages – Install — Plone Documentation v6.0 using cookiecutter-plone-starter.

I'm attempting to set up a project using Cookiecutter, and I encountered an issue when running the command cookiecutter
The error message I received is Unable to load extension: No module named 'jinja2_time' Just to clarify, I have already installed the 'jinja2_time' package using pip.