Debian Strecht with Plone 5.1.1 install

Hello, we are installing with UnifiedInstaller 5.1.1, and we have the following messages :
" Testing /usr/bin/python2.7 for Zope/Plone requirements....
/usr/bin/python2.7 looks OK. We will use it.

Unable to find libxml2 development libraries."

But in apt-get, libxml2 development appears installed in the last version.
"libxml2 is already the newest version (2.9.4+dfsg1-2.2+deb9u2).
libxml2-dbg is already the newest version (2.9.4+dfsg1-2.2+deb9u2).
libxml2-dev is already the newest version (2.9.4+dfsg1-2.2+deb9u2).
libxml2-doc is already the newest version (2.9.4+dfsg1-2.2+deb9u2).
libxml2-utils is already the newest version (2.9.4+dfsg1-2.2+deb9u2).
libxml2-utils-dbg is already the newest version (2.9.4+dfsg1-2.2+deb9u2).
"

try sudo apt-get install libxslt1-dev

I install exactly with this command, and install fine.
But in install we obtain the same massage.

Thanks for your help. If you need more information for to help me, please
ask me.

Bye

what is the output of the following commands
xml2-config --version
xslt-config --version

Hello

xml2-config --version 2.9.4

xslt-config --version "command not found"

When we ran the install script ./install.sh

that's the problem.
But this page says that if your have installed libxslt1-dev you should have xslt-config in /usr/bin so it's some mystery. Are you sure that libxslt1-dev installed correctly ?

I'm sure at this moment that libxskt1-dev is not installed,

well, install libxslt1-dev then :slight_smile: it should not be that difficult under Debian, it's a one minute thing under Ubuntu. If you really can't install this library you should search help on a Debian forum, there is something wrong on your system.

Yes I understand, I use and install Phone version 3, 4, without problems,
But in this case we have a lot of problems.

Thanks for your help. We will ask in Debian.

I m again, we update the sources list, and we try to install libxslt1-dev,
but does not find the package, but libxslt1.1 is installed in my debían.

root@donotstretchthings:~# cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux 9 (stretch)"
NAME="Debian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"
root@donotstretchthings:~# apt-get install libxslt1-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  icu-devtools libasan3 libatomic1 libc-dev-bin libc6-dev libcilkrts5 libgcc-6-dev libgomp1 libicu-dev libicu57 libitm1 liblsan0 libmpx2 libquadmath0 libstdc++-6-dev libtsan0
  libubsan0 libxml2 libxml2-dev libxslt1.1 linux-libc-dev manpages manpages-dev sgml-base xml-core
Suggested packages:
  glibc-doc icu-doc libstdc++-6-doc pkg-config man-browser sgml-base-doc debhelper
The following NEW packages will be installed:
  icu-devtools libasan3 libatomic1 libc-dev-bin libc6-dev libcilkrts5 libgcc-6-dev libgomp1 libicu-dev libicu57 libitm1 liblsan0 libmpx2 libquadmath0 libstdc++-6-dev libtsan0
  libubsan0 libxml2 libxml2-dev libxslt1-dev libxslt1.1 linux-libc-dev manpages manpages-dev sgml-base xml-core
0 upgraded, 26 newly installed, 0 to remove and 0 not upgraded.
Need to get 39.0 MB of archives.
After this operation, 191 MB of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 http://security.debian.org/debian-security stretch/updates/main amd64 libicu57 amd64 57.1-6+deb9u2 [7700 kB]

(..cut many lines...)

Setting up libxslt1-dev:amd64 (1.1.29-2.1) ...
Processing triggers for sgml-base (1.29) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
root@donotstretchthings:~# xslt-config --version
1.1.29
root@donotstretchthings:~# 

Thanks very much for your support, this is not easy procedure (for me).

Two hours ago, we decide install Ubuntu for this server.

Thanks a lot

Plone Foundation Code of Conduct