Copy of Barceloneta does not Build CSS and Themes does not show Build CSS option

I am trying to update a server that has Plone 5.0.8 to Plone 5.1.7. First, plone has been updated to version 5.0.10. Next, all sites have been updated. I noticed that when I click on "Diazo Theme", click on the "Tools" button, the "Build CCS" pop-up option does not appear. If a new copy of Barceloneta has been created, when I click on the "Tools" button, the option "Build CSS" appears, but the process does not end when it is clicked. Then, plone was updated to 5.1.7 (the same problems happen). Unfortunately, at this point, I am unable to update plone to version 5.2 because the contentwellportlet add-on was used in 5.0.8 and does not work in 5.2 (at least, I was unable to build plone).
I also tried a clean install of plone 5.0.10. I downloaded the Unified Installer (plone5.0.10), installed it without errors, cloned the Barceloneta Theme, clicked on barceloneta.plone.less and tried to "Build CSS" but the process doesn't end. Has anyone noticed these problems and knows how to solve them?

There is work done on github for this packaged, but a release is missing.

maybe try if this version works for you on Plone 5.2.x, if so ping some of the maintainers stated in pypi to make a new release.

Regarding the CSS build error, did you check the console if you see any errors there or the inspector in the browser. Would be helpful to see whats actually going wrong.
Sometimes is just somethings like encoding issues on the backend request.

1 Like

I think It just don't work on vanilla 5.2.X.

In fact, using Products.ContentWellPortlets from github solved my problem. I was able to update Plone to version 5.2.4 and sites created in this version do not have the problems when compiling Diazo themes. Now I can continue testing the migrated sites. I have also written an email to the Products.ContentWellPortlets support team to check if it is possible to generate a new release for version 5.2. Thank you very much.

Can you check if these things work in 5.2.4 (does not in my 5.2.somethingelse)

  1. Copy barceloneta TTW and edit files in themes subfolders
  2. Using a unicode character in some of the less (css) and compile or save ( for example .someclass { content: "©" } )

How to fix that ?

I copied barceloneta TTW, created a new file (ufscar.less) inside the less folder, imported ufscar.less inside barceloneta.plone.less, added .someclass :: before {content: "©"} to ufscar.less, saved and compiled barceloneta.plone.less. I also edited a document and assigned the .someclass class to a div. Works in 5.2.4.