Contenrules UI looks strange/bug (?) Plone 6 Classic

After adding a 'Notify' content rule, I noticed some strange behavior in Plone

  1. Add a new content rule 'Notify'

  2. Edit the content rule. It looks like this (see screentshot). I did not expect all the control panel settings to show

  3. When trying to save, I get the following error:

      2024-03-21 11:21:30,317 ERROR   [Zope.SiteErrorLog:36][waitress-1] AttributeError: http://ubuntu.local:8605/Plone74/++rule++rule-1/++action++2/edit
    Traceback (innermost last):
    Module ZPublisher.WSGIPublisher, line 181, in transaction_pubevents
    Module ZPublisher.WSGIPublisher, line 391, in publish_module
    Module ZPublisher.WSGIPublisher, line 285, in publish
    Module ZPublisher.mapply, line 98, in mapply
    Module ZPublisher.WSGIPublisher, line 68, in call_object
    Module plone.z3cform.layout, line 61, in __call__
    Module plone.z3cform.layout, line 45, in update
    Module plone.z3cform.fieldsets.extensible, line 62, in update
    Module plone.z3cform.patch, line 31, in GroupForm_update
    Module, line 145, in update
    Module, line 21, in execute
    Module z3c.form.action, line 98, in execute
    Module z3c.form.button, line 301, in __call__
    Module z3c.form.button, line 159, in __call__
    Module, line 67, in handle_save_action
    Module, line 58, in add
    AttributeError: 'RequestContainer' object has no attribute 'add'

I am not sure if they are related. Does anyone know when this worked 'last time' (Plone version) ?

I just tried this at and it seems to work. May you try exact the same you did locally there and report back if it is a problem and where?

It does not work when you try to 'edit the notify message' (it is blank), and as on my site: demo. plone also 'includes the site setup link and the 'control panel tabs'. This is 'confusing UI'

Update: youtube (will remove this later)

Well, please file a bug.