Connection unexpectedly closed: timed out

I'm happy with Plone (current version), which run on debian on Hyper-V virtual machine. Everything seems to work properly, but every time I try to set SMTP server, I get Connection unexpectedly closed: timed out.
I've tried three different mail servers (incl. gmail), but always get the same message. Machine has Internet access, I can telnet mail servers... Message shows in 3-5 seconds after press save and sent test email button, bo I guess there is too short timeout. Couldn't google any help - is there any solution?

This does not look like a Plone problem but rather a network problem. For example, a firewall shielding against SMTP connections would show itself in this way. Verify that the machine running your Plone instance can indeed access the mail server.

1 Like

I'm not sure if your problem comes from Plone or it's just a misunderstanding about SMTP.
What's troubling is that you said that you tried google as a mail server but did not say anything about using an actual mail account at google, just checking if you have internet access and you can telnet a mail server.

If you are are not using the mail server of your ISP you either have to

  • use an account at a mail provider and provide proper authentication (password). This is skipped when using an ISP mail server because the IP address is in this case deemed proper authentication.

  • or setup a proper mail server: these days it involves having SPF, avoiding various blacklists since 'big' providers 'fight' spam by blacklisting huge IP ranges at the slightest provocation or even denying access by default, you have to be whitelisted first.

I'd say that since you are on Hyper-V you are on an intranet, hyper-v is not used much by service providers. If this is the case you should use your corporate mail server, Exchange probably.

1 Like

Thank you for response.
We don't have our own mail server, just use mail server provided by our hosting service.
I checked SMTP connection with an actual accounts and all creditentials working on every other system (Thunderbird, Outlook). Our IP number is not listed in any blacklist, so I'll check our firewall settings once again, maybe there is something wrong.

Evertyhing works fine now. I tried ports 25, 465 but finally 587 is the proper one.