Configuring collective.easyformplugin.createdx

I have an easyform instance, and would like to use the form to create Dexterity content.

When I create a simple text case, I get an error on submission, which I think is because I am failing to understand how to correctly specify the location for content creation - I am just using the folder, so e.g. '/dxtestcase' in my example.

The error that I am getting is as follows: -

Traceback (innermost last):
Module ZPublisher.WSGIPublisher, line 162, in transaction_pubevents
Module ZPublisher.WSGIPublisher, line 371, in publish_module
Module ZPublisher.WSGIPublisher, line 266, in publish
Module ZPublisher.mapply, line 85, in mapply
Module ZPublisher.WSGIPublisher, line 63, in call_object
Module plone.z3cform.layout, line 63, in call
Module plone.z3cform.layout, line 47, in update
Module collective.easyform.browser.view, line 298, in update
Module plone.z3cform.fieldsets.extensible, line 65, in update
Module plone.z3cform.patch, line 30, in GroupForm_update
Module z3c.form.group, line 145, in update
Module plone.app.z3cform.csrf, line 22, in execute
Module z3c.form.action, line 98, in execute
Module z3c.form.button, line 315, in call
Module z3c.form.button, line 170, in call
Module collective.easyform.browser.view, line 189, in handleSubmit
Module collective.easyform.browser.view, line 152, in processActions
Module collective.easyformplugin.createdx.actions, line 101, in onSuccess
Module collective.easyformplugin.createdx.actions, line 74, in createDXItem
Module , line 2, in get
Module plone.api.validation, line 116, in wrapped
Module , line 2, in get
Module plone.api.validation, line 153, in wrapped
Module plone.api.content, line 153, in get
TypeError: startswith first arg must be bytes or a tuple of bytes, not str

Plone Foundation Code of Conduct