Collective.mailchimp portlet doesn't show z3c form in Plone 5.2

Hi Everyone,

Yesterday I tried to install the collective.mailchimp module on Plone 5.2 (zeocluster). (https://github.com/collective/collective.mailchimp).
After the installation, it shows me the settings menu 'Mailchimp' in the controlpanel.

However, when I try to add MailChimp as a footer portlet, Only the portlet title appears. Any z3c form doesn’t show up. I ran the client in foreground mode, but I don’t see any warnings of a deprecated module that could be a dependency of the collective.mailchimp module.

Do you have encountered this problem before or why could this happen?

Thanks a lot!

Steven

Hi Steven,

collective.mailchimp does not officially support Plone 5.2 yet. We did some work on it but this isn't done yet:

Feel free to report your issue there. I am the author of c.mailchimp and I'd be more than happy to help if you want to contribute fixes to make c.mailchimp compatible with Plone 5.2.

Are you on Python 2 or 3?

1 Like

Hi Tisto,

Thank you for your reply and offer to help making collective.mailchimp compatible with Plone 5.2. I would love to contribute and I will report the issue on your repository. I am using Python 3.

Plone Foundation Code of Conduct