Collection.geo types missing

Hi,
I have plone 5 all working ok, and it asked me if we wanted to convert from archetypes to dexterity, and I changed it.

the maps plugin I have for plone4 works fine. google maps api works great.
for plone5, it is not supported, and collection.geo has a lot more features.

buildout worked fine per instructions.
when i go to the config, i have 2 issues i can see:

  1. instead of tons of content types, i only have comment, folder, collection, and location (which is an old archetype from plone 4 upgrade).
    no file or other options per the documentation

  2. even with a valid API key, the map itself does not show up in the add-on config page for collection.geo

any ideas?

looks like i had to go in and manually install the atcontenttype of file and simplefile for it to add them.
not compatible with dexterity :*(

still not loading the map itself but i will keep poking unless someone has a few ideas

looks like in the dexterity options, i can go in and enable collection.geo for different types, but they never show up under the actual add-ons collection-geo config as a type.
would rather use dexterity than manually configuring older archetypes.

also, i don't see anywhere to add a new lat/long/etc on any files/images/or add a location?

Plone Foundation Code of Conduct