Change to the Core Development category

For some time the Core Development category hasn't been obviously named (to many)... It was intended to distinguish between Plone core and Plone add-ons.

We've renamed it to Development to better reflect its umbrella nature (it contains many subcategories).

We've also added a new Development -> Roadmap subcategory.

Plone Foundation Code of Conduct