Can't start Plone

Hello Plone community,

after an upgrade from Debian 7 to Debian 8 I can't start Plone

Linux 4.9.0-0.bpo.5-amd64
Version Overview
Plone 4.3.3 (4308)
CMF 2.2.7
Zope 2.13.22
Python 2.7.3 (default, Mar 13 2014, 11:03:55) [GCC 4.7.2]
PIL 2.3.0 (Pillow)

Here is the folder where I have Plone installed:

root@doc:/usr/local/Plone/zeocluster

drwxr-sr-x 6 root plone_group 4096 Jan 18 20:08 ?
drwxr-sr-x 11 plone_buildout plone_group 4096 Jan 18 20:33 .
drwxr-sr-x 6 plone_buildout plone_group 4096 Oct 7 2014 ..
-rw------- 1 plone_buildout plone_group 431 Nov 18 2016 adminPassword.txt
-rw-r--r-- 1 plone_buildout plone_group 8768 Oct 7 2014 base.cfg
drwxr-sr-x 3 plone_buildout plone_group 4096 Jan 18 20:33 bin
-rw-r--r-- 1 plone_buildout plone_group 5686 Oct 7 2014 bootstrap.py
-rw------- 1 plone_buildout plone_group 6690 Nov 18 2016 buildout.cfg
-rw-r--r-- 1 plone_buildout plone_group 4399 Oct 7 2014 develop.cfg
drwxr-sr-x 2 plone_buildout plone_group 4096 Oct 7 2014 develop-eggs
drwxr-sr-x 2 root plone_group 4096 Jan 18 20:22 include
-rw------- 1 plone_buildout plone_group 18824 Nov 18 2016 .installed.cfg
drwxr-sr-x 3 root plone_group 4096 Jan 18 20:22 lib
-rw-r--r-- 1 plone_buildout plone_group 759 Oct 7 2014 lxml_static.cfg
drwxr-sr-x 5 plone_buildout plone_group 4096 Nov 18 2016 parts
drwxr-sr-x 2 plone_buildout plone_group 4096 Oct 7 2014 products
-rw-r--r-- 1 plone_buildout plone_group 3469 Nov 18 2016 README.html
drwxr-sr-x 3 plone_buildout plone_group 4096 Oct 7 2014 src
drwxrws--- 12 plone_buildout plone_group 4096 Jan 15 03:00 var
-rw-r--r-- 1 plone_buildout plone_group 9587 Oct 7 2014 versions.cfg
-rw-r--r-- 1 plone_buildout plone_group 1917 Oct 7 2014 zopeapp-versions.cfg
-rw-r--r-- 1 plone_buildout plone_group 1029 Oct 7 2014 zope-versions.cfg
-rw-r--r-- 1 plone_buildout plone_group 2533 Oct 7 2014 ztk-versions.cfg

Following this guide:
https://docs.plone.org/4/en/manage/deploying/processes.html

I get this error:

root@doc:/usr/local/Plone/zeocluster# sudo -u plone_buildout bin/zeoserver start
Traceback (most recent call last):
File "bin/zeoserver", line 22, in
import plone.recipe.zeoserver.ctl
File "/usr/local/Plone/buildout-cache/eggs/plone.recipe.zeoserver-1.2.6-py2.7.egg/plone/recipe/zeoserver/init.py", line 6, in
from pkg_resources import get_distribution
File "/usr/local/Plone/buildout-cache/eggs/setuptools-0.7.2-py2.7.egg/pkg_resources.py", line 16, in
File "/usr/lib/python2.7/zipfile.py", line 6, in
import io
File "/usr/lib/python2.7/io.py", line 51, in
import _io
ImportError: No module named _io

Same error for command: sudo -u plone_buildout bin/plonectl start

Any ideas?

Thanks

Thanks for your ideas, but I've checked also this and I don't know what I have to do. I mean, where is the "corrupted" virtualenv in order to remove it? Where I have to create a new one? Which requeriments this virtualenv need in order to start Plone successfully? Which user has to create it?

I know these are dumb questions.. sorry but I don't get it :frowning:

Well I was just pointing that it was not a Plone specific problem, more of a Python problem.
Plone is not always using a virtualenv. My guess is that you have a python executable in the bin directory (the one where you are starting zeoserver or plonectl). This is the one that was not updated (since it is in a user private directory, it is to be expected). The solution used by your Plone (with or without virtual env) has the goal to isolate the Plone python from the python libraries, but your system is not isolated from the python updates themselves (and this is a good thing, since python updates are intended often to fix security problems).
If you start your Plone python directly by doing something along the lines of sudo su plone_buildout, cd bin, ./python2.7, you will get a python prompt.
If you then enter import sys then sys.path, you will understand the problem. You will see that your python interpreter use system python libraries, outside your Plone environment.
So in this case I'd try just to replace the Plone python interpreter (python2.7) by the new updated system python interpreter (it is probably in /usr/bin/python2.7). Then it should work at least no worse :slight_smile:

HTH

Finally I managed to solve it. You were right!

Just replacing the interpreter python2.7 for the updated one and it worked. I was stucked till i got the idea about env outdated python and although I get updated main python install, the point was with the outdated pyhton exec

Thanks a lot for your advice. Much appreciated! :slight_smile:

Plone Foundation Code of Conduct