Can't login to Plone

Hello,

I can't login to Plone since a migration from webfaction to a2hosting.
I'm using Plone 3.0.3 (Zope 2.10)

I can access the ZMI and change the password in acl_users/source_users
But when I'm trying logging in (in a different browser instance), Plone redirects me to the login_form without any error. Nothing in the log files.

When I'm trying to use the already logged user (in the ZMI) in Plone, I get an error if I have already tried to connect with the Plone user:
Request URL |http://xxx.xxx.xxx.xxx:xxxx/my_plone/index_html
Exception Type |AttributeError
Exception Value |portal_groups
...
URL: file:/home/xxx/webapps/zope/Zope/Products/CMFPlone/skins/plone_templates/global_defines.pt
Line 8, Column 0
Expression: <PathExpr standard:u'plone_view/globalize'>
{'container': <PloneSite at /my_plone>,
'context': <PloneSite at /my_plone>,
'default': <object object at 0x7f1c962d0200>,
'here': <PloneSite at /my_plone>,
'loop': {},
'nothing': None,
'options': {'args': ()},
'repeat': <Products.PageTemplates.Expressions.SafeMapping object at 0x7f1c87871cf8>,
'request': <HTTPRequest, URL=http://xxx.xxx.xxx.xxx:xxxx/my_plone/index_html>,
'root': ,
'template': <ZopePageTemplate at /my_plone/index_html>,
'traverse_subpath': ,
'user': <UnrestrictedUser 'plone_user_xxx'>}

If I've not tried to connect using the Plone user before, I can log into Plone using the Zope user.
So, it seems I'm kind of logged in even if Plone tells me I'm not.
example 1:
logged in the ZMI as zope_user_xxx
never tried to log into Plone
-> I can administrate Plone using the zope_user_xxx (defined in the root acl_users)
example 2:
logged in the ZMI as zope_user_xxx
tried to log into Plone at least once using plone_user_xxx
-> I can't get into Plone (error)

On my local installation, which is an exact copy (not 100% sure though) of the production one, I don't have the same behavior. I can log into Plone without any problem.

I know this version of Plone is quite old now (I had to use python 2.4 :smiley: ) and I don't have the time to try to upgrade it it would be great if someone could help me on this issue.

Thank you.

Regards,

Coulď it be permissions on some files?

To learn more, I would first do the following:

  • reconfigure error_log not to ignore Unauthorized

  • reconfigure Zope to use verbose security

If you are lucky, your error log will show interesting information for the problem.

As a side note: when you report exceptions, it is helpful to include (relevant parts of) the traceback.

Thank you Dieter. I'll follow your tips as soon as I have some time to debug this issue. I only have a few time during the week-end to manage that website. That's why I only answer after a week.
And, of course, you are completely right to ask for the traceback. I usually post the complete traceback when reporting a problem. Don't know why I didn't did it. Perhaps the size of the traceback.

Regards,

Just checked and no. But thanks for the tip.

Others know this (kind of errors) better than me, but I just want to mention:

  • if you have some kind of error on a page/view, you might be getting a 'login page' even if that is not the real problem:
  • I think that this can also happen if some permissions on files are wrong. Maybe you could test this by setting rwx for everyone for all the files (or the files in /src and /Products )

I wouldn’t do that, certainly not before trying many other things

Why not? It is just to take a backup of the folders and replace them afterwards (?)

with your zope admin:

  1. add a user to plone->acl_users->source_users
  2. go to plone->acl_users and check your source_groups and portal_role_manager, add your created user to Siteadmins and Admins group
  3. logout your zope admin
  4. login with your created plone-admin

general, don't use zope admin user to adminstrate a plone site.

if you need a emergency user for zope, use:

bin/instance stop
bin/instance adduser $USERNAME $PASSWORD
bin/instance start

Plone Foundation Code of Conduct