Can not add new "Plone Site" from Plone ZMI

hi all,
at job i got the task to create new Plone site from existing Plone intranets.

as I read books, i logged in and opened the ZMI (...mo.cz/manage),
within the ZMI i selected Plone Site from "Add new..." drop-down menu
near the top right to add a new Plone site,

but i can not get a form to enter the ID of new Plone Site!

I saw same strange links like
Skip to content. | Skip to navigation
and a lot of links to other contents,
but no where to enter the Id for new Plone Site.
see https://imgur.com/a/3O2rPJ5

Please could you give an advice? Is there a way
to add new Plone Site via

bin/client1 debug

? many thank for your time.

Looks like you add a Plone site inside another.
That is bad.

If you see control panel in the ZMI, you are in the right place. If not: don't add a Plone site (there)

Skjermbilde 2020-04-27 kl. 18.13.57

You're logged into the root of a Plone site and not into the root of Zope. You need to access the Zope root through a non-vhosted port. You can not add a Plone site within a Plone. You can only add Plone site within the Zope root.

1 Like

thank you guys for hints,
zopyx, I connected to port 7081 where Zope is running
and i see the screen

https://imgur.com/a/DiT7AK2

but another big problem is: we have no password for root user
to login to Zope, so we can not create new Plone site!

I check google and tried few things but it does not help:

  1. add new user
    bin/client1 adduser admin v123456
  2. create emergency user
    bin/zpasswd access
    these 2 commands ended with error ... some packeages are missing.

so I tried to create user with 'Manager' permission:
bin/client2 debug

import transaction
transaction.begin()
<transaction._transaction.Transaction object at 0x27b6c90>

app.acl_users._doAddUser('adminv', 'pwd123456', ['Manager'], )
<PropertiedUser 'adminv'>

transaction.commit()

seems the user adminv is created with 'Manager' role,
but when come back to img above, we still can not
login to Zope with user adminv.

Please could you give us hint, how to create 'admin' user
in order to create new Plone site?

Many thanks

Could you in the future please use an inline image source (I hate to configure cookies before I see information).

The image gives the impression as if you were already authenticated. What happens, when you press "Create a new Plone site"?


this putty tunnel to remote server at port 7081

thank you for advice.

This command should work fine. Maybe it does not work because admin already exists. Try creating another user like admin2. Once you are logged in you can go to acl_users (from Zope root) -> users and change admin password

$ bin/client1 adduser admin2 pwd123

$ Created user: admin2

csanahuja, i still can not login :frowning: with that admin2 user
via above link http://localhost:8080/@@plone-addsite?site_id=Plone

our intranets are running by

  • Plone 4.1.4 (4113)

  • CMF 2.2.5

  • Zope 2.13.12

  • Python 2.6.6 (r266:84292, Jan 22 2014, 09:42:36) [GCC 4.4.7 20120313 (Red Hat 4.4.7-4)]

  • PIL 1.1.6

When you execute the command does the terminal say something like:

Created user: admin2

If so it should work. The docs https://docs.plone.org/manage/deploying/zope.html#adding-users-from-command-line also say to stop the client first (I just tested in a 5.2 and wasn't required for me). If you have two clients configured you could try to stop one and give it a try

csanahuja, thx for link to the plone zope doc,

in order you have the picture of my situation, i will show you these commands:

[zope@server]$ tail bin/client1
import plone.recipe.zope2instance.ctl

if name == 'main':
plone.recipe.zope2instance.ctl.main(
["-C", '/srv/data/divisions/parts/client1/etc/zope.conf']
+ sys.argv[1:])
[zope@server]$ view /srv/data/divisions/parts/client1/etc/zope.conf
i see:
http-server>
address 127.0.0.1:7081

and i have correctly set up putty tunnel to remote server at port 7081,

then i ran these commands:
[zope@server]$ bin/zeoserver status
program running; pid=3590

[zope@server]$ bin/client1 stop
.
daemon process stopped
[zope@server]$ bin/client1 help adduser
adduser -- add a Zope management user
[zope@server]$ bin/client1 adduser admin3 pwd123
it outputs some warnings but at last line i saw clearly:
Created user: admin3

but i still can not login with zope admin3:

thx for advices :slight_smile:

Any change you are still logged in the plone website with a user only belongs to the site? Try to logout of the site or login in new private navigation window / other browser

csanahuja, i dont understand the question, we running few intranets based on these 2 plone clients. Yes i tried to login to zope in incognito window but still can not go to next step.

dieter, what do you mean about "authenticated", to what?

i am getting crazy, zope management user correctly created but i can not log in.

I see now by your capture that it says: "Your Plone site has not been added yet".
Typically it should list the plone sites created, see:

In your previous post you mentioned you had one Plone site and you wanted to add more. Can you verify if you are accesing through localhost to correct server and port?

Plone Foundation Code of Conduct