Bobtemplates.plone 3.4.2 version conflict with Plone 5.x

Installing mrbob.
  Version and requirements information containing unidecode:
  [versions] constraint on unidecode: 0.04.1
Requirement of python-slugify: Unidecode>=0.04.16
 Installing mrbob.

Looks like version 3.4.2 of bobtemplates added python-slugify to the install requires,

This conflicts with the unidecode 0.04.1 version pin in

I am now pinning bobtemplates to 3.3.0 (3.4.1 should work too) in my versions.cfg and all seems to be ok.

Comments? Suggestions? Me too? Better ideas?

(This post here mostly to help future googlers)

This might be a valid bug for bobtemplates.plone - only because bobtemplates.plone is supposed to to work with plone, after all. But I'd rather get some feedback here before picking on the package itself.