Bin/buildout -c develop.cfg install error

I am working on Plone 5.0.5 and trying to overwrite a few styles in the look and feel. In order to do so I am trying to install mrbob and the rest of the tool in develop.cgf but when I run the buildout it returns this error:
An internal error occurred due to a bug in either zc.buildout or in a
recipe being used:
Traceback (most recent call last):
File "/home/happy141/public_html/happycamp/lib/python2.7/site-packages/zc/buildout/", line 1995, in main
getattr(buildout, command)(args)
File "/home/happy141/public_html/happycamp/lib/python2.7/site-packages/zc/buildout/", line 666, in install
installed_files = self[part]._call(recipe.install)
File "/home/happy141/public_html/happycamp/lib/python2.7/site-packages/zc/buildout/", line 1410, in _call
return f()
File "/home/happy141/public_html/buildout-cache/eggs/plone.recipe.precompiler-0.6-py2.7.egg/plone/recipe/precompiler/", line 29, in install
return self._run()
File "/home/happy141/public_html/buildout-cache/eggs/plone.recipe.precompiler-0.6-py2.7.egg/plone/recipe/precompiler/", line 35, in _run
File "/home/happy141/public_html/buildout-cache/eggs/plone.recipe.precompiler-0.6-py2.7.egg/plone/recipe/precompiler/", line 67, in _compile_eggs
py_compile.compile(fn, None, None, True)
File "/home/happy141/public_html/Python-2.7/lib/python2.7/", line 123, in compile
with open(cfile, 'wb') as fc:
IOError: [Errno 13] Permission denied: '/home/happy141/public_html/buildout-cache/eggs/Products.DocFinderTab-1.0.5-py2.7.egg/Products/init.pyc'

It kills the install and I can't go forward. I appreciate any help.

Thank you.

Looks like you do not have filesystem read permissions in your buildout or some subdirectory. Since it seems you're in user space, did you accidentally run buildout prior with sudo? Anyway, use chown to correct this.

Thank you for the help Jens.
Here is the command I use to run buildout;
sudo -u plone_buildout bin/buildout - as directed by the installer how-to on, so I did use sudo to run buildout.
Which directory ownership is in question, and who should the owner be?
Thanks again.

buildout-cache is owned by my username. That it should be owned by plone_buildout is theproblem you are suggesting?

Solved[quote="noirman, post:4, topic:2650, full:true"]
Hello,buildout-cache is owned by my username. That it should be owned by plone_buildout is theproblem you are suggesting?Norman

Solved. Changed owner of buildout-cache to plone-buildout and ran bin/bouildout -c develop.cfg without problems.