Behold: pip install Plone works!

Pinching myself. Just ran the command:
bin/pip install Plone -c https://dist.plone.org/release/6.0-dev/constraints.txt -f https://dist.plone.org/release/6.0-dev/ --use-deprecated legacy-resolver

.... and pip-based Plone just installed!
This is a non-trivial milestone, maximum respect to all that have worked on this!

What do I do next?
How do I spin up a new instance?

1 Like
bin/mkwsgiinstance -u admin:admin -d .
bin/runwsgi -v etc/zope.ini

See also Plone 6.x Docker Official Image with pip

1 Like

Thanks @avoinea.
It worked! There was no feedback on the terminal when I ran mkwsgiinstance but was able to use runwsgi to launch against the generated .ini file.
I know this is Alpha stuff. My immediate thoughts:

  1. I love that I can simply edit an ini file and not have to rerun buildout to change my ports and other settings.
  2. This opens up a simpler workflow for small deployments (a global runwsgi command).
  3. feedback on the terminal should say what just happened "generated zope.ini file, it is located here, use runwsgi to run it"
  4. Wondering if renaming these commands would better match what a user is attempting to do.
    In this case they want to initialize a new plone site or instance.
    maybe:
    bin/ploneinit or bin/plonecreate

Here are the screenshots of where I've reached:




(the margins can get a bit tight with certain breakpoints)

PRs or bug reports at the issue tracker (wink) are welcome!

Started a draft here.... Create utility with meaningful name for initializing and managing wsgi based Plone sites (ploneinit and plonerun) · Issue #3324 · plone/Products.CMFPlone · GitHub

Got this error
Traceback (most recent call last):
File "/home/michael/plone6/alpha/bin/instance", line 14, in
import plone.recipe.zope2instance.ctl
ModuleNotFoundError: No module named 'plone.recipe'

./bin/python -V
Python 3.9.7

Help this?

python3.9 -m venv .
bin/python -m pip install "pip==19.2.3"
bin/pip install -U setuptools wheel
bin/pip install Plone -c https://dist.plone.org/release/6.0-dev/constraints.txt -f https://dist.plone.org/release/6.0-dev/

yes, this works. Thanks.

Plone Foundation Code of Conduct