Volto - Create New Volto App / Project - No Stylesheet

I cloned the Volto github repo and followed the instructions to create a new Volto project
( npm init yo @plone/volto). Then I moved to the new subfolder and run 'yarn start' inside it. This created a new Volto site at :3000. I could view this site within the browser, but it has no css style. It is only raw HTML. The header of the site contains links to js-files, but no link to a css file.
I used the current state of the volto github repo.
I tried again with 'npx @plone/create-volto-app my-volto-app' and 'yarn start' (explained on the Volto training site), but this results in the same issue.
I run this on Debian 11 inside a Linux container.

I get the usual output in the shell, once I run yarn start:

Server-side HMR Enabled!
Volto is running in SEAMLESS mode
Using internal proxy: http://localhost:3000 -> http://localhost:8080/Plone
:performing_arts: Volto started at http://localhost:3000

I run Volto also on Debian 11 inside virtual machine (VirtualBox) and
the Volto shows the usual styling.
I looked into the structure of this environment and searched for
differences, but couldn't find one.
I'm a bit puzzled.

Hi @andreasma , Did you try opening it in incognito? I also suspect the theming engine doesn't got installed properly. Try removing node_modules and yarn install. Also in which port you have Plone running?

I looked into it further and further again and found the issue today. I open the Volto front end in a browser from another machine. The default Volto configuration uses 'localhost:3000'. If I call Volto from another machine I could not point to 'localhost', but instead to the IP of the the Volto-server and port 3000. Thus I had to add the 'HOST' and 'PORT' variable to the 'yarn start' command, e.g.:

HOST=my_server_ip PORT=3000 yarn start

With this command I could reach Volto and the site got styles.

Plone Foundation Code of Conduct