Upgrading Plone 4.3.6 to 4.3.7 or 4.3.8 on Windows fails

Looking for any MS users who has had problems with
4,3.7 - fails to find server after successful buildout and
4.3.8 - error with setuptools in script
any suggestions or workarounds appreciated. Currently using 4.3.6

I've had success with 4.3.8 with this procedure:


Many thanks Steve, I got it to work with a little interpretation. Time to do task 2h15m
I have two separate Plone 4.3.6 applications that I need to upgrade to 4.3.8 which I will now look at doing.

Will let you know, but you've shown the destination is achievable,

Tried Steve's How-To with 4.3.9 soft-release and it worked for me on Windows 7 64bit.( I still consider myself on-the-job-training)

Now have to close the gap (migrate) working upgraded 4.3.6 site to Steve's clean 4.3.8 site.

My next learning curve. :o)

I'm still fiddling with MS upgrade from 4.3.6 to 4.3.7 - If I did as I was told on plone.org site, I get connection errors. Tonight I did a variation of the 4.3.6 buildout.cfg file by changing 3 lines only on 4.3.6
find-links +=

Plone = 4.3.7
Products.CMFPlone = 4.3.7

localhost:8080 connected

Offered me the upgrade:from 4310 to 4311
Plone 4.3.7
Zope 2.13.20

When I did the dry run I got the following errors

Traceback (innermost last):
Module ZPublisher.Publish, line 126, in publish
Module ZPublisher.mapply, line 77, in mapply
Module ZPublisher.Publish, line 46, in call_object
Module Products.CMFPlone.browser.admin, line 241, in call
Module , line 3, in upgrade
Module AccessControl.requestmethod, line 70, in _curried
Module Products.CMFPlone.MigrationTool, line 276, in upgrade
Module Products.CMFPlone.MigrationTool, line 86, in upgrade_all
AttributeError: upgradeProfile

Can anyone decypher this for me please.

I hope this helps those who have been using MS.