Upgrade Plone 5.0 --> 5.06 results in "application/javascript" page

I have upgraded a Plone 5.0 plone site to 5.0.6. Now it is displayed as plain text. The following error message is displayed when running foreground: Products.CMFPlone Error compiling js/css for the bundle

I have removed all installed addons but it does not help. Is there something I miss?

Installed Plone 5.0.6 from installer. Imported zexp. The page is displayed as plaintext before and after upgrading the site. Any help/hint would be appreciated.

Did you run the upgrade?

Is there anything in your error log?

If you played with the resource registries and something is wrong, you can go to /@@resourceregistry-controlpanel -> overrides and delete all the ones that say "customized". Or, go to portal_resources/resource_overrides/production/manage and portal_resources/resource_overrides/static/manage and delete everything there.

As Nathan says, you have to upgrade the site after updating the software.

If you got errors upgrading the site, post the full log here.

Also check your browser's console for errors.

/@@resourceregistry-controlpanel does not work as it is displayed as plain text as well.

Btw the page is in plain text before and after I make the upgrade. I have another page running on the same instance that works fine.

  • Both pages created in plone 5.0.
  • I delelte the resource overrides in ZMI (portal_resources/resource_overrides)
  • uninstalled the theme
  • Tried: Imported via ZMI + copiy Data.fs & Blob
  • installed the working theme from the working page - no effect

An still the only error I get: INFO Products.CMFPlone Error compiling js/css for the bundle

When I create a new plone site and install the theme - it works.

I did upgrade the page. But the update runs smooth .. no error messages.

I found that the problem comes up in Products.CMFPlone.resoureces.browser.configjs.ConfigJsView

When I change the response header to text/html I can access the page and portal_resources + the page is displayed as expeced (no javascript or css errors). Nevertheless, there is no error in the resource registry as there is no custom bundle.

I just noticed you said you imported a .zexp file. That is not the recommended way to upgrade a Plone site. Instead (hm, can't find docs on it), you should install the new Plone version in another directory, and then copy in your Data.fs and blobstorage folders from the old site you're upgrading.

Have you tried these troubleshooting ideas? http://docs.plone.org/manage/upgrading/troubleshooting.html

Because importing a .zexp can cause problems, here's the best way to upgrade a Plone site: