Unknown type name: 'temporarystorage' after installing PloneHotfix20210518

I just installed this last hotfix on my very new 5.2.4 Plone using the following command

sudo -u plone_buildout bin/instance fg

It compiled properly

But when I start my Plone instance, I see this error message:

sudo -u plone_daemon bin/plonectl start
instance: Error: unknown type name: 'temporarystorage'
(line 29 in file:zinstance/parts/instance/etc/zope.conf)

I'm quite lost, do you know what can I do to correct this?

Thanks by advance

Could we see the contents of that zope.conf file?

What steps did you follow to install Plone? Did it start ok before you added the hotfix?

Thanks for your answer, here is my zope.conf file:

%define INSTANCEHOME /srv/www/htdocs/Plone/zinstance/parts/instance
instancehome $INSTANCEHOME
%define CLIENTHOME /srv/www/htdocs/Plone/zinstance/var/instance
clienthome $CLIENTHOME
debug-mode off
security-policy-implementation C
verbose-security off
default-zpublisher-encoding utf-8
    zope_i18n_compile_mo_files true
PYTHON_EGG_CACHE /srv/www/htdocs/Plone/zinstance/var/.python-eggs
CHAMELEON_CACHE /srv/www/htdocs/Plone/zinstance/var/cache
<zodb_db main>
    # Main database
    cache-size 30000
    # Blob-enabled FileStorage database
      blob-dir /srv/www/htdocs/Plone/zinstance/var/blobstorage
      # FileStorage database
        path /srv/www/htdocs/Plone/zinstance/var/filestorage/Data.fs
    mount-point /
<zodb_db temporary>
    # Temporary storage database (for sessions)
      name temporary storage for sessioning
    mount-point /temp_folder
    container-class Products.TemporaryFolder.TemporaryContainer
python-check-interval 1000

I first created the destination folder and gave it the good unix rights:

mkdir /srv/www/htdocs/Plone
chown plone_buildout.plone_group /srv/www/htdocs/Plone

Then I launched the unified installer:
./install.sh --target=/srv/www/htdocs/Plone/ standalone

Finally I launched Plone:

sudo -u plone_daemon bin/plonectl start

Yes, Plone worked perfectly until I added the hotfix

tempstorage (which defines temporarystorage) does not work reliably under Zope 4+ (and therefore Plone 5.2.x); newer Zope versions therefore no longer include it.

I assume that your problem has the following cause: tempstorage is no longer available/activated (which makes temporarystorage unknown) and your zope.conf still uses it.

You could try to rerun buildout and check whether a newly generated zope.conf still uses temporarystorage. If this is not the case, this problem should be gone.
Otherwise, check the plone.recipe.zope2instance documentation (--> PyPI) and look for options to control the generation of the section temporary; this is related to sessions and therefore session might be part of the option name..

Do you still have the console or terminal output from when you added the hotfix? I wonder how the zope.conf would have changed like that.

Thanks a lot for your help.

@dieter I rerun buildout and despite 2 compiling errors (Error while compiling language file), I was able to launch again Plone.
The command I launched:

sudo -u plone_buildout ./bin/buildout -Nv

I cannot edit the subject to add Solved, could an admin do it for me? Thanks by advance

@tkimnguyen unfortunately not, I closed the terminal.

One more strange thing I just compared the new zope.conf and the problematic one: no difference :astonished:

And the Module menu has disappeared...