TOC portlet hidden by default?

We're using using Plone 5.1 and on some of our pages we'd like to enable the Table of Contents. When we go into Edit->Settings and check the "Show Table of Contents" box, the TOC div does appear in the HTML, but the style is forced to display: none so it doesn't appear on the page. The TOC portlet also appears to be empty, even though there's several heading elements on the page. The page is being edited through the WYSIWYG editor.

In the Portlet Manager, I don't see any entry for the TOC portlet, so I don't know how to configure it. How do I get the table of contents for the page to show up?

For those who stumble across this topic in the future, here's how I fixed it....

There are actually two facilities for adding a table of contents to the page when you check the box that says "Table of Contents".

The first is a dynamically generated viewlet that is described here:

The second is a JavaScript-based table of contents and this is the topic I used to learn about it:

Bottom line, you can use either a Diazo style to show the "autotoc" JS-based TOC, or go into ZMI to enable the Plone-based TOC.

1 Like

Are you sure about this: For me the TOC works OOTB (all I have to do is enable it (in the setting for the page). Could it be that your theme 'filters it out'. Does the same thing happen with default barceloneta theme.

Checked on Plone 5.0.x and 5.1.5