TinyMCE Rich Text Editor gone

The TinyMCE Rich Text Editor is not loading. I had resolved such a issue in plone 4.3 but not able to move ahead in plone 5.0. Where should i look for this issue.

Is there anyway to reload TinyMCE?
Will building a bundle in Resource registry resolve the issue?

This could be a javascript issue. If you use another theme than Barceloneta, change to that and see if it helps.
If not, you probably installed some add on or added some javascript that messes things up, try uninstalling it.

tried to build the plone bundle. Is everything alright?

Bundle Builder
building javascripts
Saved javascript bundle, Build results:

building CSS bundle
1 css files to build
Error building bundle
Error in build process
finished saving css bundles
CloseBuild it

i was trying to do some changes in tinymce but not adding any javascript.

I think my plone-logged-in bundle may have some issues. Building it again. I hope this resolves the issue. Will update again.
Also ran an upgrade from 5.0.3 to 5.0.4. This did not resolve the issue.


how do i check what is going wrong and why the tinymce editor is gone. Following error from the console

plone-logged-in-compiled.js:46244 Uncaught TypeError: Cannot read property 'title' of null
(anonymous function) @ plone-logged-in-compiled.js:46244
c @ plone-logged-in-compiled.js:7271
b @ plone-logged-in-compiled.js:46242
(anonymous function) @ plone-logged-in-compiled.js:46249
c @ plone-logged-in-compiled.js:7271
b @ plone-logged-in-compiled.js:46242
c @ plone-logged-in-compiled.js:46273
e @ plone-logged-in-compiled.js:46292
g @ plone-logged-in-compiled.js:46337
(anonymous function) @ plone-logged-in-compiled.js:46139
e @ plone-logged-in-compiled.js:27597
fire @ plone-logged-in-compiled.js:27916
p.add @ plone-logged-in-compiled.js:42488
E.init @ plone-logged-in-compiled.js:39885
(anonymous function) @ plone-logged-in-compiled.js:39864
(anonymous function) @ plone-logged-in-compiled.js:13250
c @ plone-logged-in-compiled.js:7271
o @ plone-logged-in-compiled.js:13249
(anonymous function) @ plone-logged-in-compiled.js:13242
e @ plone-logged-in-compiled.js:13084

You could tell us if there are any errors on the JS console.

Hi Davi

I can see the following error:

Uncaught TypeError: Cannot read property 'title' of null




  • go to site setup
  • "resource registries" control panel
  • overrides
  • find the plone-logged-in-compiled.js customization
  • delete

You might have screwed up bundle definition where it isn't compiling correctly now. Deleting the custom build will use the default build shipped with Plone.

Also, if you enable development mode for the plone-logged-in bundle js file, you might get a better idea of what the error is about with a better traceback.

there is no such entry in overrides

sorry, ++plone++static/plone-logged-in-compiled.js to be more exact.

Go to the overrides tab and see what is listed as "customized".

Did you try turning on dev mode and see the error stack?

I was looking for that only. However, since i have been struggling from a long time and i didnt get that, I deleted all customisation. The change is that i have started getting the colors in the tool bar correctly. But the tinymce editor is missing.

Yes i tried to enable debug mode. but dont see any new errors in console. (apart from some of things i have deleted now). The old error continues.

Error stack - Are you referring to the error log in the control panel. No errors in that. I am using it TTW in my blog-site.

The issue started when I went to TinyMCE and added something under the block styles. I have deleted that now. But that is how it started.

I'm looking for errors in the browser console that would prevent tiny from loading.

It is started when messing with tiny settings, maybe start a fresh site and see what the differences are and see where it went wrong.

Yes i will do that. thanks

The only difference i find with my other site is below. tinymce loads correctly in this

Uncaught plone-logged-in-compiled.js:46244

TypeError: Cannot read property 'title' of null

Also, you may need to re-save the resource registries to force building js/css. Might not be required though--not certain all the cases that force that to be re-built.

Going into dev mode should help you identify the problem though in any case.

@sudhan77 I'm having the same issue. did you ever resolve it?

Yes I resolved it with help from Nathan.

My issue arose as I had tried to include a block in TinyMCE. Although I removed it, the editor was gone. There may have been a bug due to some blank lines.

I again encountered the same problem while I was trying to introduce a template. However, this time around I corrected the errors and TinyMCE editor was up.

Just recall what changes you had done that led to this issue. Go to resource registries > overrides > check for the JS that are customised (you may be getting that as errors in browser console when you check development mode)

If you remove customisation and resave the resource registries will re-built from default settings.


1 Like

I put in a couple PRs to fix the problem