Testing plone on macos Sierra

I was just testing plone on macos environment and I know we can install Plone on OS X with Unified UNIX Installer but is it compatible with sierra?
I got this error while running this command
bin/plonectl fg


I've installed xcode and command line tools and other dependent tools like libjpeg, libreadline, poppler with brew.

1 Like

Did you already tried asking google?

This search looks promising for me:

If everything else fails, you can set the locale in the buildout file, something like

environment-vars =

(probably change to your_language

thanks for help it worked.
@alert @espenmn

1 Like

Thanks for the Homebrew suggestion @kakshay21! I was just installing Plone on my Mac OS Sierra (10.12.3), and the only dependency I was missing was libjpeg. A simple "brew install libjpeg" in Terminal did the trick. Love Homebrew! :slight_smile:

1 Like

Glad to hear that @sgrepos
And Welcome to Plone community!:slight_smile:

Would it be the case do add Homebrew to documentation in https://docs.plone.org/manage/installing/installation.html#installing-plone-using-the-unified-unix-installer, https://docs.plone.org/manage/deploying/preparing.html and https://docs.plone.org/4/en/manage/deploying/preparing.html?

yeah I would love to! @idgserpro

I think we are ending up with duplicate information which is hard to maintain. The installers each have their own instructions and manage dependencies differently. The recommended install for Mac is the unified installer which explains how to get missing packages via brew.