Staging behavior not showing up in Plone 4.2

we have a site running Plone 4.2 with some plugins installed, among them, collective.cover.

yesterday I upgraded it to the latest version and, as at some point we removed the hard dependency, I added it to the list of eggs in my policy package.

after running buildout and executing the upgrade steps we discovered that the staging behavior was not available (the checkin/checkout actions); we went to the behavior list on the collective.cover content type and try to manually re-enabled it, but it continued not showing up.

In : setSite(site)
In : obj = site['my-cover']
In : obj.portal_type
In : from import IStagingSupport
In : IStagingSupport.providedBy(obj)
In : from import IIterateAware
In : IIterateAware.providedBy(obj)

any ideas of what happened and/or how to fix it?

  • Products.CMFPlone 4.2.5 with latest hotfixes installed
  • 0.1
  • 2.1.18

versioning is enabled in the content type:

I have more information: this site is behind Cloudflare, nginx and Varnish, so I tried at every end point and found something weird:

at instance and Varnish levels the behavior is showing up:

but it get lost at nginx:

my nginx configuration is basically this:

location / {
    if ($request_uri ~* ".(avi|css|flv|gif|gz|htc|ico|jpeg|jpg|js|mov|mp3|mpeg|mpg|png|rar|swf|txt|wmv|woff|zip)$") {
        expires 7d;

    proxy_cache backcache;
    proxy_cache_bypass $http_cache_control $cookie___ac;
    add_header X-Proxy-Cache $upstream_cache_status;
    proxy_pass http://varnish/VirtualHostBase/http/;
    proxy_http_version 1.1;
    proxy_set_header Connection "";
    proxy_ignore_headers Expires;

any hints?

nginx 1.8.1.

after disabling the latest security patch (Products.PloneHotfix20161129==1.2) the problem was solved; I opened an issue about this:

Very strange!

yes, but I think it was my mistake and not a bug on the hotfix; site is working now and I don't want to mess on it until weekend to confirm this.

1 Like

I can confirm this is not an issue; it was my fault: I had 5 instances running but the script that restarted them had a typo and only 4 of were updated.

I fixed that and now everything is working normally.