Some plone instances failing to launch while others work? [Resolved]

I have a number of plone 5.0.4 and 5.0.5 instances that were running before I shut my server down in a controlled manner for a building wide power outage. Some of my instances launch fine, but some of them now will not start.
Launching with 'plonectl start' yields: 'ImportError: No module named recipe.egg'
It appears to by trying to import zc.recipe.egg.

These instances have their own python2.7 installations.

If I try to run buildout I also get an error message, but this time about not finding 'DateTime'. I can find the egg for DateTime.

Instances that run and those that don't both seem to have zc.recipe.egg-2.0.3-py2.7.egg in the eggs directory of the builduout-cache.

I would appreciate any ideas people have for resurrecting these sites.

At this point my best idea is to install a new plone instance of the same version and then just swap the Database, since this appears to be a problem with the installation not the database.


My idea of installing a new plone instance and swapping in the old database and blobstorage appears to have worked. However, I would really like to figure out what happened. Any ideas?

What is the difference between the buildout configuration files?

To debug launch problems you should run with fg e.g. see

I would never run buildout while trying to figure out why something isn't running that was running before... running buildout in such circumstances is like loading a gun and pointing at your head... not going to end well :slight_smile:

That's the odd thing. All but one have the same buildout.cfg (except for the port number and initial admin password). One of the ones that stayed running had a couple of non-default packages, but others that worked were plain vanilla. All the ones that didn't launch were plain vanilla. I am suspicious of some non-obvious file or file-system damage. I got no fdisk warnings.

The errors were the same in fg and using plain start.


Yeah, you're correct, but I hoped that rerunning buildout might correct a potentially bad file reference...In this case no-harm done as I resurrected the sites using an alternative method.